summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-25 09:40:43 +0200
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-30 23:46:08 +0200
commitef551cc032716d8cb21ecfdff73bb6c2bc581740 (patch)
tree68d9418eb1128b98b1072b590e953bb788b82ee6 /CMakeLists.txt
parent87357352c9db1b94289afbfce017ed9a0bd89dcc (diff)
downloadxmr-stak-ef551cc032716d8cb21ecfdff73bb6c2bc581740.zip
xmr-stak-ef551cc032716d8cb21ecfdff73bb6c2bc581740.tar.gz
fix windows compile
- fix build documentation - fix plugin load methods - fix symbol export for plugins
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ff459f..8871951 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -390,7 +390,7 @@ if( NOT "${CMAKE_INSTALL_PREFIX}" STREQUAL "${PROJECT_BINARY_DIR}" )
LIBRARY DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
endif()
endif()
-
+else()
set(WIN_OUTPUT_RELEASE "/Release")
endif()
@@ -400,7 +400,7 @@ install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/opencl"
# avoid overwrite of user defined settings
# install `config.txt`if file not exists in `${CMAKE_INSTALL_PREFIX}/bin`
install(CODE " \
- if(NOT EXISTS ${CMAKE_INSTALL_PREFIX}/bin/config.txt)\n \
+ if(NOT EXISTS ${CMAKE_INSTALL_PREFIX}/bin${WIN_OUTPUT_RELEASE}/config.txt)\n \
file(INSTALL ${CMAKE_CURRENT_SOURCE_DIR}/config.txt \
DESTINATION ${CMAKE_INSTALL_PREFIX}/bin${WIN_OUTPUT_RELEASE})\n \
endif()"
OpenPOWER on IntegriCloud