summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfireice-uk <fireice-uk@users.noreply.github.com>2017-12-15 22:36:20 +0000
committerGitHub <noreply@github.com>2017-12-15 22:36:20 +0000
commitca2889da21dd25641ced4ee685e79b2c6b147c29 (patch)
tree0eb0ed1dd51ab6af2f5069066df993cc06125da5 /CMakeLists.txt
parent04288f643571e91224ebfdc244e790757bd0823e (diff)
parent31c7598168debeaad26e91e36409a25808a8a6c4 (diff)
downloadxmr-stak-ca2889da21dd25641ced4ee685e79b2c6b147c29.zip
xmr-stak-ca2889da21dd25641ced4ee685e79b2c6b147c29.tar.gz
Merge pull request #549 from psychocrypt/fix-cuda91WindowsCompile
fix windows compile with CUDA 9.1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 87ba391..0fa831d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -195,7 +195,9 @@ if(CUDA_ENABLE)
set(CUDA_NVCC_FLAGS "${CUDA_NVCC_FLAGS}" "-D_MWAITXINTRIN_H_INCLUDED")
endif()
- if(CMAKE_CXX_COMPILER_ID MATCHES "MSVC" AND CUDA_VERSION VERSION_EQUAL 9.0)
+ if(CMAKE_CXX_COMPILER_ID MATCHES "MSVC" AND
+ (CUDA_VERSION VERSION_EQUAL 9.0 OR CUDA_VERSION VERSION_EQUAL 9.1)
+ )
# workaround find_package(CUDA) is using the wrong path to the CXX host compiler
# overwrite the CUDA host compiler variable with the used CXX MSVC
set(CUDA_HOST_COMPILER ${CMAKE_CXX_COMPILER} CACHE FILEPATH "Host side compiler used by NVCC" FORCE)
OpenPOWER on IntegriCloud