summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-29 22:08:17 +0200
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-30 23:46:08 +0200
commita3c034e46ab933fe07d0c6e829074d79866dd4b5 (patch)
tree9f38c78b26b4e3bd89b61db6f14573bd17d1a5b0 /CMakeLists.txt
parent855af1cf65de1fd3795de3c9a859fd9242625a84 (diff)
downloadxmr-stak-a3c034e46ab933fe07d0c6e829074d79866dd4b5.zip
xmr-stak-a3c034e46ab933fe07d0c6e829074d79866dd4b5.tar.gz
rename binary to xmr-stak
- add pseudo install rule to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8eff475..5c60292 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -373,14 +373,14 @@ set_source_files_properties(${SRCFILES_CPP} PROPERTIES LANGUAGE CXX)
set_property(TARGET xmr-stak-c PROPERTY C_STANDARD 99)
target_link_libraries(xmr-stak-c ${LIBS})
-add_executable(xmr-stak-cpu
+add_executable(xmr-stak
${SRCFILES_CPP}
)
set(EXECUTABLE_OUTPUT_PATH "bin")
set(LIBRARY_OUTPUT_PATH "bin")
-target_link_libraries(xmr-stak-cpu ${LIBS} xmr-stak-c xmr-stak-backend)
+target_link_libraries(xmr-stak ${LIBS} xmr-stak-c xmr-stak-backend)
################################################################################
# Install
@@ -389,7 +389,7 @@ target_link_libraries(xmr-stak-cpu ${LIBS} xmr-stak-c xmr-stak-backend)
# do not install the binary if the project and install are equal
if( NOT "${CMAKE_INSTALL_PREFIX}" STREQUAL "${PROJECT_BINARY_DIR}" )
- install(TARGETS xmr-stak-cpu
+ install(TARGETS xmr-stak
RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
if(CUDA_FOUND)
if(WIN32)
@@ -410,5 +410,6 @@ if( NOT "${CMAKE_INSTALL_PREFIX}" STREQUAL "${PROJECT_BINARY_DIR}" )
endif()
endif()
else()
- set(WIN_OUTPUT_RELEASE "/Release")
+ # this rule is used if the install prefix is the build directory
+ install(CODE "MESSAGE(\"xmr-stak installed to folder 'bin'\")")
endif()
OpenPOWER on IntegriCloud