summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-27 18:07:19 +0200
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-30 23:46:08 +0200
commit990c357cc97792e761f40adfbc6445fb30d04d30 (patch)
treed09beda9e59cd50533c1cef402a5bafbc2f56cb9 /CMakeLists.txt
parent9e7efd40bc3206aad7b6d1e531dbe6d335575aac (diff)
downloadxmr-stak-990c357cc97792e761f40adfbc6445fb30d04d30.zip
xmr-stak-990c357cc97792e761f40adfbc6445fb30d04d30.tar.gz
improve auto suggestion
- amd/nvidia add hard limit that 64MiB memory keeps free - improve nvidia auto suggestion (take care of lmem) - add c++11 flag to nvidia compiler
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8871951..cf776e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,6 +108,11 @@ if(CUDA_ENABLE)
endforeach()
elseif("${CUDA_COMPILER}" STREQUAL "nvcc")
+ # add c++11 for cuda
+ if(NOT "${CMAKE_CXX_FLAGS}" MATCHES "-std=c\\+\\+11")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+ endif()
+
# avoid that nvcc in CUDA < 8 tries to use libc `memcpy` within the kernel
if(CUDA_VERSION VERSION_LESS 8.0)
add_definitions(-D_FORCE_INLINES)
OpenPOWER on IntegriCloud