summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-10-11 21:25:48 +0200
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-10-11 21:25:48 +0200
commit8d313484e488b9f2be5be9150bb05234e2b9f77c (patch)
tree6ba8df700c478275a70371c13096f5926ad4a886 /CMakeLists.txt
parent01b4460b957af8a58a4eccfc3d66f9a08ab609b4 (diff)
downloadxmr-stak-8d313484e488b9f2be5be9150bb05234e2b9f77c.zip
xmr-stak-8d313484e488b9f2be5be9150bb05234e2b9f77c.tar.gz
fix cuda 7.5 compile
fix error: `identifier "__builtin_ia32_monitorx" is undefined`
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a3df96..c23fce3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -142,7 +142,11 @@ if(CUDA_ENABLE)
if(CUDA_KEEP_FILES)
set(CUDA_NVCC_FLAGS "${CUDA_NVCC_FLAGS}" --keep --keep-dir "${PROJECT_BINARY_DIR}")
endif(CUDA_KEEP_FILES)
-
+
+ if(CUDA_VERSION VERSION_LESS 8.0)
+ # for CUDA 7.5 fix compile error: https://github.com/fireice-uk/xmr-stak/issues/34
+ set(CUDA_NVCC_FLAGS "${CUDA_NVCC_FLAGS}" "-D_MWAITXINTRIN_H_INCLUDED")
+ endif()
else()
message(FATAL_ERROR "selected CUDA compiler '${CUDA_COMPILER}' is not supported")
endif()
OpenPOWER on IntegriCloud