summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-11-30 22:46:00 +0100
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-12-06 22:21:48 +0100
commit7ca6f6e2e9bd5f7a68c878a60a296af1a3636c6f (patch)
tree3e6762e99bbedd8f6cb0a3d7a919af27451038ca /CMakeLists.txt
parent47a4d031bcc3159a298afaae6797cd19240ad0a1 (diff)
downloadxmr-stak-7ca6f6e2e9bd5f7a68c878a60a296af1a3636c6f.zip
xmr-stak-7ca6f6e2e9bd5f7a68c878a60a296af1a3636c6f.tar.gz
allow to diable UAC dialog
- remove CMake option `WIN_UAC` - spawn UAC dialog via restarting xmr-miner with administrator right - allow to disable UAC with `--noUAC` - update documentation - remove usage section with help message (output depends on OS)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a444085..9540d7a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -521,12 +521,6 @@ set(LIBRARY_OUTPUT_PATH "bin")
target_link_libraries(xmr-stak ${LIBS} xmr-stak-c xmr-stak-backend)
-option(WIN_UAC "Add UAC manifest on Windows" ON)
-
-if(WIN_UAC AND CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
- set_property(TARGET xmr-stak PROPERTY LINK_FLAGS "/level='requireAdministrator' /uiAccess='false'")
-endif()
-
################################################################################
# Install
################################################################################
OpenPOWER on IntegriCloud