summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2018-04-06 15:11:07 -0400
committerTimothy Pearson <tpearson@raptorengineering.com>2018-06-04 21:07:11 +0000
commit262c0a7791c7ddbbfde89747d3a6675eac1c5a8e (patch)
tree6ef582e6fe1f808e532339c82a804e6606848e48 /CMakeLists.txt
parent21c1e3bac244858470a2ba9d0dd61128b92b0fb2 (diff)
downloadxmr-stak-262c0a7791c7ddbbfde89747d3a6675eac1c5a8e.zip
xmr-stak-262c0a7791c7ddbbfde89747d3a6675eac1c5a8e.tar.gz
Allow EXECUTABLE and LIBRARY paths to be set
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2adba65..49acf71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -522,8 +522,8 @@ else()
add_executable(xmr-stak ${SRCFILES_CPP})
endif()
-set(EXECUTABLE_OUTPUT_PATH "bin")
-set(LIBRARY_OUTPUT_PATH "bin")
+set(EXECUTABLE_OUTPUT_PATH "bin" CACHE STRING "Path to place executables relative to ${CMAKE_INSTALL_PREFIX}")
+set(LIBRARY_OUTPUT_PATH "bin" CACHE STRING "Path to place libraries relative to ${CMAKE_INSTALL_PREFIX}")
target_link_libraries(xmr-stak ${LIBS} xmr-stak-c xmr-stak-backend)
OpenPOWER on IntegriCloud