summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfireice-uk <fireice-uk@users.noreply.github.com>2017-10-14 14:44:34 +0100
committerfireice-uk <fireice-uk@users.noreply.github.com>2017-10-14 14:44:34 +0100
commit1fc87d737fcba5b254603893403b92ffe99c6247 (patch)
tree2b153f5e794daf05149db89f71d6bbd354888e46 /CMakeLists.txt
parentca7e27b78477c0d87583dadf4122c5f305283e9c (diff)
downloadxmr-stak-1fc87d737fcba5b254603893403b92ffe99c6247.zip
xmr-stak-1fc87d737fcba5b254603893403b92ffe99c6247.tar.gz
Re-add UAC manifest and WIN_UAC cmake option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ee800e..015f7c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -413,6 +413,12 @@ set(LIBRARY_OUTPUT_PATH "bin")
target_link_libraries(xmr-stak ${LIBS} xmr-stak-c xmr-stak-backend)
+option(WIN_UAC "Add UAC manifest on Windows" ON)
+
+if(WIN_UAC AND CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
+ set_property(TARGET xmr-stak PROPERTY LINK_FLAGS "/level='requireAdministrator' /uiAccess='false'")
+endif()
+
################################################################################
# Install
################################################################################
OpenPOWER on IntegriCloud