summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-10-26 20:58:27 +0200
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-10-27 20:13:19 +0200
commit12802f12e30f57c2a9eefca2c1a5955275c95127 (patch)
treea10bced239ecd012ceeed593571a3fb8bccee9cb /CMakeLists.txt
parent41451d91e8e50f2b6c4b07630987dbc5a58aecb9 (diff)
downloadxmr-stak-12802f12e30f57c2a9eefca2c1a5955275c95127.zip
xmr-stak-12802f12e30f57c2a9eefca2c1a5955275c95127.tar.gz
rename `xmr` to `monero`
- rename all `xmr` to `monero` - be insensitive while check for set currency - add function to compate two strings insensitive
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 332f226..595631d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,15 +37,15 @@ endif()
set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS "${BUILD_TYPE}")
set(XMR-STAK_CURRENCY "all" CACHE STRING "select miner currency")
-set_property(CACHE XMR-STAK_CURRENCY PROPERTY STRINGS "all;xmr;aeon")
+set_property(CACHE XMR-STAK_CURRENCY PROPERTY STRINGS "all;monero;aeon")
if("${XMR-STAK_CURRENCY}" STREQUAL "all")
- message(STATUS "set miner currency to 'xmr' and 'aeon'")
+ message(STATUS "Set miner currency to 'monero' and 'aeon'")
elseif("${XMR-STAK_CURRENCY}" STREQUAL "aeon")
- message(STATUS "set miner currency to 'aeon'")
- add_definitions("-DCONF_NO_XMR=1")
-elseif("${XMR-STAK_CURRENCY}" STREQUAL "xmr")
- message(STATUS "set miner currency to 'xmr'")
+ message(STATUS "Set miner currency to 'aeon'")
+ add_definitions("-DCONF_NO_MONERO=1")
+elseif("${XMR-STAK_CURRENCY}" STREQUAL "monero")
+ message(STATUS "Set miner currency to 'monero'")
add_definitions("-DCONF_NO_AEON=1")
endif()
OpenPOWER on IntegriCloud