summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfireice-uk <fireice-uk@users.noreply.github.com>2017-07-18 16:44:49 +0100
committerfireice-uk <fireice-uk@users.noreply.github.com>2017-07-18 16:44:49 +0100
commitd189f1444164b8422e311b9b219597957d08143f (patch)
tree415382200793be03861b84c70c4b9434dc0d3134 /CMakeLists.txt
parent4d0845e1de657cae2717f1311615e884ceeb12df (diff)
downloadxmr-stak-d189f1444164b8422e311b9b219597957d08143f.zip
xmr-stak-d189f1444164b8422e311b9b219597957d08143f.tar.gz
Windows cmake fix and .gitignore to match WINDOWS.md
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 738256e..3b85f2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,18 @@ set(LIBS ${LIBS} ${CMAKE_THREAD_LIBS_INIT})
option(MICROHTTPD_ENABLE "Enable or disable the requirement of microhttp (http deamon)" ON)
if(MICROHTTPD_ENABLE)
+ find_path(MTHD_INCLUDE_DIR
+ NAMES
+ microhttpd.h
+ PATHS
+ /opt/local
+ /usr/local
+ /usr
+ ENV "PROGRAMFILES(X86)"
+ ENV "HWLOC_ROOT"
+ PATH_SUFFIXES
+ include)
+
find_library(MHTD
NAMES
microhttpd
@@ -62,6 +74,7 @@ if(MICROHTTPD_ENABLE)
message(FATAL_ERROR "microhttpd NOT found: use `-DMICROHTTPD_ENABLE=OFF` to build without http deamon support")
else()
set(LIBS ${LIBS} ${MHTD})
+ include_directories(AFTER ${MTHD_INCLUDE_DIR})
endif()
else()
add_definitions("-DCONF_NO_HTTPD")
OpenPOWER on IntegriCloud