summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfireice-uk <fireice2@o2.pl>2017-02-12 16:40:37 +0000
committerfireice-uk <fireice2@o2.pl>2017-02-12 16:40:37 +0000
commitf84ed4b9a825a882a68b4e41a35ebc98fb2cf953 (patch)
tree522d9f4344bbe9983982ada5c2dd9de5689e92dc /CMakeLists.txt
parent1b4f0dd57be74bcd5e724d7910243a5c6712e7d8 (diff)
downloadxmr-stak-f84ed4b9a825a882a68b4e41a35ebc98fb2cf953.zip
xmr-stak-f84ed4b9a825a882a68b4e41a35ebc98fb2cf953.tar.gz
Include OpenSSL in CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b377c22..2e19674 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,8 @@ if("${MHTD}" STREQUAL "MHTD-NOTFOUND")
message(FATAL_ERROR "libmicrohttpd is required")
endif()
+find_package(OpenSSL REQUIRED)
+
#set(CMAKE_VERBOSE_MAKEFILE ON)
set(CMAKE_CONFIGURATION_TYPES "RELEASE;STATIC")
if("${CMAKE_BUILD_TYPE}" STREQUAL "")
@@ -30,6 +32,6 @@ set(EXECUTABLE_OUTPUT_PATH "bin")
file(GLOB SOURCES "crypto/*.c" "crypto/*.cpp" "*.cpp")
add_executable(xmr-stak-cpu ${SOURCES})
-target_link_libraries(xmr-stak-cpu pthread microhttpd)
+target_link_libraries(xmr-stak-cpu pthread microhttpd crypto ssl)
OpenPOWER on IntegriCloud