summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfireice-uk <fireice-uk@users.noreply.github.com>2017-10-11 22:39:22 +0100
committerGitHub <noreply@github.com>2017-10-11 22:39:22 +0100
commitb40f937bf592f3fb303ce51fc073ab6ee9f922d0 (patch)
tree8f67c23cfa455420e0358dbab64079beda8723ef /CMakeLists.txt
parentfa5518309ed4f8c615ddf9d28e353da9a8c48846 (diff)
parent8d313484e488b9f2be5be9150bb05234e2b9f77c (diff)
downloadxmr-stak-b40f937bf592f3fb303ce51fc073ab6ee9f922d0.zip
xmr-stak-b40f937bf592f3fb303ce51fc073ab6ee9f922d0.tar.gz
Merge pull request #35 from psychocrypt/fix-cuda7_5Compile
fix cuda 7.5 compile
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e42639..0ee800e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,7 +150,11 @@ if(CUDA_ENABLE)
if(CUDA_KEEP_FILES)
set(CUDA_NVCC_FLAGS "${CUDA_NVCC_FLAGS}" --keep --keep-dir "${PROJECT_BINARY_DIR}")
endif(CUDA_KEEP_FILES)
-
+
+ if(CUDA_VERSION VERSION_LESS 8.0)
+ # for CUDA 7.5 fix compile error: https://github.com/fireice-uk/xmr-stak/issues/34
+ set(CUDA_NVCC_FLAGS "${CUDA_NVCC_FLAGS}" "-D_MWAITXINTRIN_H_INCLUDED")
+ endif()
else()
message(FATAL_ERROR "selected CUDA compiler '${CUDA_COMPILER}' is not supported")
endif()
OpenPOWER on IntegriCloud