summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-05-01 21:11:22 +0200
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-05-01 21:15:52 +0200
commitb352b360e1324c46b90dd6e8614aed4abfa8fbfb (patch)
tree7e7a6accfd6c0288760b230264a7531fd17e22a9 /CMakeLists.txt
parent924a1f8c8ae1be3526bcf3d8587076afebebcaee (diff)
downloadxmr-stak-b352b360e1324c46b90dd6e8614aed4abfa8fbfb.zip
xmr-stak-b352b360e1324c46b90dd6e8614aed4abfa8fbfb.tar.gz
allow to fully disable OpenSSL and microhttpd
- rename option `*_REQUIRED` to `*_ENABLE` - allow to disable the dependency OpenSSL and microhttpd
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt35
1 files changed, 16 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68d2432..2373d85 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,36 +48,33 @@ set(LIBS ${LIBS} ${CMAKE_THREAD_LIBS_INIT})
# Find microhttpd
################################################################################
-option(MICROHTTPD_REQUIRED "Enable or disable the requirement of microhttp (http deamon)" ON)
-find_library(MHTD NAMES microhttpd)
-if("${MHTD}" STREQUAL "MHTD-NOTFOUND")
- if(MICROHTTPD_REQUIRED)
- message(FATAL_ERROR "microhttpd NOT found: use `-DMICROHTTPD_REQUIRED=OFF` to build without http deamon support")
+option(MICROHTTPD_ENABLE "Enable or disable the requirement of microhttp (http deamon)" ON)
+if(MICROHTTPD_ENABLE)
+ find_library(MHTD NAMES microhttpd)
+ if("${MHTD}" STREQUAL "MHTD-NOTFOUND")
+ message(FATAL_ERROR "microhttpd NOT found: use `-DMICROHTTPD_ENABLE=OFF` to build without http deamon support")
else()
- message(STATUS "microhttpd NOT found: disable http server")
- add_definitions("-DCONF_NO_HTTPD")
+ set(LIBS ${LIBS} ${MHTD})
endif()
else()
- set(LIBS ${LIBS} ${MHTD})
+ add_definitions("-DCONF_NO_HTTPD")
endif()
###############################################################################
# Find OpenSSL
###############################################################################
-option(OpenSSL_REQUIRED "Enable or disable the requirement of OpenSSL" ON)
-find_package(OpenSSL)
-if(OPENSSL_FOUND)
- include_directories(${OPENSSL_INCLUDE_DIR})
- set(LIBS ${LIBS} ${OPENSSL_LIBRARIES})
-else()
- if(OpenSSL_REQUIRED)
- message(FATAL_ERROR "OpenSSL NOT found: use `-DOpenSSL_REQUIRED=OFF` to build without SSL support")
+option(OpenSSL_ENABLE "Enable or disable the requirement of OpenSSL" ON)
+if(OpenSSL_ENABLE)
+ find_package(OpenSSL)
+ if(OPENSSL_FOUND)
+ include_directories(${OPENSSL_INCLUDE_DIR})
+ set(LIBS ${LIBS} ${OPENSSL_LIBRARIES})
else()
- if(NOT OPENSSL_FOUND)
- add_definitions("-DCONF_NO_TLS")
- endif()
+ message(FATAL_ERROR "OpenSSL NOT found: use `-DOpenSSL_ENABLE=OFF` to build without SSL support")
endif()
+else()
+ add_definitions("-DCONF_NO_TLS")
endif()
################################################################################
OpenPOWER on IntegriCloud