summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfireice-uk <fireice-uk@users.noreply.github.com>2017-07-18 17:11:10 +0100
committerfireice-uk <fireice-uk@users.noreply.github.com>2017-07-18 17:11:10 +0100
commitacdc560b8acd02d3a2d11c45df6ce1f9224e88c9 (patch)
treebdb9d2ae25aa40293ff4d9561532cad5868973f3 /CMakeLists.txt
parentd189f1444164b8422e311b9b219597957d08143f (diff)
downloadxmr-stak-acdc560b8acd02d3a2d11c45df6ce1f9224e88c9.zip
xmr-stak-acdc560b8acd02d3a2d11c45df6ce1f9224e88c9.tar.gz
Amend cmake to skip GCC options for MSVC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b85f2e..0a056be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,7 +74,7 @@ if(MICROHTTPD_ENABLE)
message(FATAL_ERROR "microhttpd NOT found: use `-DMICROHTTPD_ENABLE=OFF` to build without http deamon support")
else()
set(LIBS ${LIBS} ${MHTD})
- include_directories(AFTER ${MTHD_INCLUDE_DIR})
+ include_directories(AFTER ${MTHD_INCLUDE_DIR})
endif()
else()
add_definitions("-DCONF_NO_HTTPD")
@@ -147,8 +147,10 @@ endif()
################################################################################
# activate sse2 and aes-ni
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse2 -maes")
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -msse2 -maes")
+if(NOT CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse2 -maes")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -msse2 -maes")
+endif()
# activate static libgcc and libstdc++ linking
if(CMAKE_LINK_STATIC)
OpenPOWER on IntegriCloud