summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfireice-uk <fireice2@o2.pl>2017-01-16 00:59:05 +0000
committerfireice-uk <fireice2@o2.pl>2017-01-16 00:59:05 +0000
commit9c9df104bd804beaf989859f2df525a98df86d54 (patch)
treee566b7727669bdd4c012b2514986d65df564cec9 /CMakeLists.txt
parent2033ed3628b617d3f369ee0bb006b2d5cdf71199 (diff)
downloadxmr-stak-9c9df104bd804beaf989859f2df525a98df86d54.zip
xmr-stak-9c9df104bd804beaf989859f2df525a98df86d54.tar.gz
Further httpd integration
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ba2457..ee1a8db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,11 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
endif()
endif()
+find_library(MHTD NAMES microhttpd)
+if("${MHTD}" STREQUAL "MHTD-NOTFOUND")
+ message(FATAL_ERROR "libmicrohttpd is required")
+endif()
+
#set(CMAKE_VERBOSE_MAKEFILE ON)
set(CMAKE_CONFIGURATION_TYPES "RELEASE;STATIC")
if("${CMAKE_BUILD_TYPE}" STREQUAL "")
@@ -25,6 +30,6 @@ set(EXECUTABLE_OUTPUT_PATH "bin")
file(GLOB SOURCES "crypto/*.c" "*.cpp")
add_executable(xmr-stak-cpu ${SOURCES})
-target_link_libraries(xmr-stak-cpu pthread)
+target_link_libraries(xmr-stak-cpu pthread microhttpd)
OpenPOWER on IntegriCloud