summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfireice-uk <fireice2@o2.pl>2017-01-02 12:51:13 +0000
committerfireice-uk <fireice2@o2.pl>2017-01-02 12:51:13 +0000
commit6368ab745532d273775875f16a6053fb79586bc1 (patch)
treeeb472eebbbfc700662e150c7dfe17338678de794 /CMakeLists.txt
parent1384d2654117a4e9f5d2e34e74a872f1d551e22b (diff)
downloadxmr-stak-6368ab745532d273775875f16a6053fb79586bc1.zip
xmr-stak-6368ab745532d273775875f16a6053fb79586bc1.tar.gz
First!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..cf66841
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,23 @@
+project(xmr-stak-cpu)
+
+cmake_minimum_required(VERSION 2.8.10)
+
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
+ if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.1)
+ message(FATAL_ERROR "GCC version must be at least 5.1!")
+ endif()
+endif()
+
+#SET(CMAKE_VERBOSE_MAKEFILE ON)
+SET(CMAKE_C_FLAGS "-DNDEBUG -march=westmere -O3 -m64")
+SET(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -std=c++11")
+SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "-s")
+SET(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS "-s")
+set(EXECUTABLE_OUTPUT_PATH "bin")
+
+file(GLOB SOURCES "crypto/*.c" "*.cpp")
+
+add_executable(xmr-stak-cpu ${SOURCES})
+target_link_libraries(xmr-stak-cpu pthread)
+
+
OpenPOWER on IntegriCloud