summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-28 23:12:53 +0200
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-30 23:46:08 +0200
commit39d144639f837ee4a49c25158c2385f007d01417 (patch)
tree7781efbe569249059f3e6383a41260f45af1abaf /CMakeLists.txt
parent82242501b02d19cf6549d35c5b8a8dd2a62a84d0 (diff)
downloadxmr-stak-39d144639f837ee4a49c25158c2385f007d01417.zip
xmr-stak-39d144639f837ee4a49c25158c2385f007d01417.tar.gz
config as template
- create config on startup - remove copy `config.txt` on `make install`
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ade87b2..f818209 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -398,12 +398,3 @@ if( NOT "${CMAKE_INSTALL_PREFIX}" STREQUAL "${PROJECT_BINARY_DIR}" )
else()
set(WIN_OUTPUT_RELEASE "/Release")
endif()
-
-# avoid overwrite of user defined settings
-# install `config.txt`if file not exists in `${CMAKE_INSTALL_PREFIX}/bin`
-install(CODE " \
- if(NOT EXISTS ${CMAKE_INSTALL_PREFIX}/bin${WIN_OUTPUT_RELEASE}/config.txt)\n \
- file(INSTALL ${CMAKE_CURRENT_SOURCE_DIR}/config.txt \
- DESTINATION ${CMAKE_INSTALL_PREFIX}/bin${WIN_OUTPUT_RELEASE})\n \
- endif()"
-)
OpenPOWER on IntegriCloud