summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-24 21:32:09 +0200
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-09-30 23:46:08 +0200
commit2c5c6f382a74538ceb028a61e49ebd01447efaa4 (patch)
tree719e773fa3e8afc0fb4248aaeaa6812e75561fe3 /CMakeLists.txt
parent47a9063e270bc6c8bc766560b1c304f1ba8bf9c4 (diff)
downloadxmr-stak-2c5c6f382a74538ceb028a61e49ebd01447efaa4.zip
xmr-stak-2c5c6f382a74538ceb028a61e49ebd01447efaa4.tar.gz
add option to disable CPU backend
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9cbddd..6ff459f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,7 +43,7 @@ option(CMAKE_LINK_STATIC "link as much as possible libraries static" OFF)
#option(CUDA_USE_STATIC_CUDA_RUNTIME "Use the static version of the CUDA runtime library if available" OFF)
#set(CUDA_USE_STATIC_CUDA_RUNTIME OFF CACHE BOOL "Use the static version of the CUDA runtime library if available" FORCE)
-option(CUDA_ENABLE "Enable or disable NVIDIA CUDA support" ON)
+option(CUDA_ENABLE "Enable or disable CUDA support (NVIDIA backend)" ON)
if(CUDA_ENABLE)
find_package(CUDA 7.5 QUIET)
@@ -155,7 +155,7 @@ list(APPEND CMAKE_PREFIX_PATH "$ENV{CMAKE_PREFIX_PATH}")
# Find OpenCL
###############################################################################
-option(OpenCL_ENABLE "Enable or disable the requirement of hwloc" ON)
+option(OpenCL_ENABLE "Enable or disable OpenCL spport (AMD GPU support)" ON)
if(OpenCL_ENABLE)
find_package(OpenCL QUIET)
if(OpenCL_FOUND)
@@ -169,6 +169,15 @@ else()
add_definitions("-DCONF_NO_OPENCL")
endif()
+###############################################################################
+# CPU backend
+###############################################################################
+
+option(CPU_ENABLE "Enable or disable CPU support" ON)
+if(NOT CPU_ENABLE)
+ add_definitions("-DCONF_NO_CPU")
+endif()
+
################################################################################
# Find PThreads
################################################################################
OpenPOWER on IntegriCloud