summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordimecoin <dimecoin@users.noreply.github.com>2017-01-13 13:18:47 -0600
committerGitHub <noreply@github.com>2017-01-13 13:18:47 -0600
commit07c0252e84b4d474fac518127228e7a41e72403e (patch)
tree4bf2e9d2c6651b6995399a2235a81b9e7b504f58 /CMakeLists.txt
parente3bda576251367f4c5e48b7830d525d3708e08c5 (diff)
downloadxmr-stak-07c0252e84b4d474fac518127228e7a41e72403e.zip
xmr-stak-07c0252e84b4d474fac518127228e7a41e72403e.tar.gz
Update static flags to fix seg fault
-static will compile, but causes a segment fault on both build and target. Using the new flags compiles cleanly and runs on both build and target. (Build = debian sid [test], Target= debian jessie [stable])
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ce3c76..3ba2457 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,7 +18,7 @@ set(CMAKE_C_FLAGS "-DNDEBUG -march=westmere -O3 -m64 -s")
set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -std=c++11")
set(CMAKE_EXE_LINKER_FLAGS_RELSEASE "")
-set(CMAKE_EXE_LINKER_FLAGS_STATIC "-static")
+set(CMAKE_EXE_LINKER_FLAGS_STATIC "-static-libgcc -static-libstdc++")
set(EXECUTABLE_OUTPUT_PATH "bin")
OpenPOWER on IntegriCloud