summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocryptHPC@gmail.com>2017-12-13 20:44:13 +0100
committerpsychocrypt <psychocryptHPC@gmail.com>2017-12-14 21:27:19 +0100
commit74378a5ab5f5ef3290a62e284b9008892489079a (patch)
treef8b8cd2313c03918f378baad64dacff72b6714a6 /CMakeLists.txt
parentb6d319e973521dcde1e5d5dbf35add0678ac71da (diff)
downloadxmr-stak-74378a5ab5f5ef3290a62e284b9008892489079a.zip
xmr-stak-74378a5ab5f5ef3290a62e284b9008892489079a.tar.gz
fix cuda9.1 compile
- fix cuda9.1 compile (remove includ eof device_functions.hpp/ removed with cuda9.1) - remove NVIDIA Volta gpus for MAC OSX
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b8f1eef..87ba391 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,7 +108,11 @@ if(CUDA_ENABLE)
endif()
# add Volta support for CUDA >= 9.0
if(NOT CUDA_VERSION VERSION_LESS 9.0)
- list(APPEND DEFAULT_CUDA_ARCH "70")
+ # Volta GPUs are currently not supported on MACOSX
+ # https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html#cuda-general-known-issues
+ if(NOT APPLE)
+ list(APPEND DEFAULT_CUDA_ARCH "70")
+ endif()
endif()
set(CUDA_ARCH "${DEFAULT_CUDA_ARCH}" CACHE STRING "Set GPU architecture (semicolon separated list, e.g. '-DCUDA_ARCH=20;35;60')")
OpenPOWER on IntegriCloud