summaryrefslogtreecommitdiffstats
path: root/sound/pci/lola/lola.c
Commit message (Collapse)AuthorAgeFilesLines
* ALSA: module_param: make bool parameters really boolRusty Russell2011-12-191-1/+1
| | | | | | | | | | | | module_param(bool) used to counter-intuitively take an int. In fddd5201 (mid-2009) we allowed bool or int/unsigned int using a messy trick. It's time to remove the int/unsigned int option. For this version it'll simply give a warning, but it'll break next kernel version. Signed-off-by: Rusty Russell <rusty@rustcorp.com.au> Signed-off-by: Takashi Iwai <tiwai@suse.de>
* sound: fix drivers needing module.h not moduleparam.hPaul Gortmaker2011-10-311-1/+1
| | | | | | | | | The implicit presence of module.h lured several users into incorrectly thinking that they only needed/used modparam.h but once we clean up the module.h presence, these will show up as build failures, so fix 'em now. Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
* Merge branch 'fix/hda' into topic/miscTakashi Iwai2011-06-171-1/+1
|\
| * ALSA: lola - Fix section mismatchTakashi Iwai2011-06-151-1/+1
| | | | | | | | | | | | Add missing __devinit. Signed-off-by: Takashi Iwai <tiwai@suse.de>
* | ALSA: use KBUILD_MODNAME for request_irq argument in sound/pci/*Takashi Iwai2011-06-101-1/+1
| | | | | | | | | | | | | | | | | | The name argument of request_irq() appears in /proc/interrupts, and it's quite ugly when the name entry contains a space or special letters. In general, it's simpler and more readable when the module name appears there, so let's replace all entries with KBUILD_MODNAME. Signed-off-by: Takashi Iwai <tiwai@suse.de>
* | ALSA: Use KBUILD_MODNAME for pci_driver.name entriesTakashi Iwai2011-06-101-1/+1
|/ | | | | | | | | | | | The convention for pci_driver.name entry in kernel drivers seem to be the module name or equivalent ones. But, so far, almost all PCI sound drivers use more verbose name like "ABC Xyz (12)", and these are fairly confusing when appearing as a file name. This patch converts the all pci_driver.name entries in sound/pci/* to use KBUILD_MODNAME for more unified appearance. Signed-off-by: Takashi Iwai <tiwai@suse.de>
* ALSA: lola - Implement polling_mode like hd-audioTakashi Iwai2011-05-031-1/+11
| | | | | | Also protect the call of lola_update_rirb() with spinlock. Signed-off-by: Takashi Iwai <tiwai@suse.de>
* ALSA: lola - Allow granularity changesTakashi Iwai2011-05-031-5/+22
| | | | | | | Add some sanity checks. Change PCM parameters appropriately per granularity. Signed-off-by: Takashi Iwai <tiwai@suse.de>
* ALSA: lola - Use SG-bufferTakashi Iwai2011-05-031-1/+0
| | | | | | Completely switch to SG-buffer now, as it's working stably. Signed-off-by: Takashi Iwai <tiwai@suse.de>
* ALSA: lola - Add Lola-specific module optionsTakashi Iwai2011-05-031-10/+35
| | | | | | | | | | | Added granularity and sample_rate_min module options. The former controls the h/w access granularity. As default, it's set to the max value 32. The latter controls the minimum sample rate in Hz, as default 16000. Signed-off-by: Takashi Iwai <tiwai@suse.de>
* ALSA: lola - Fix PCM stallsTakashi Iwai2011-05-031-4/+13
| | | | Signed-off-by: Takashi Iwai <tiwai@suse.de>
* ALSA: lola - Suppress the debug printTakashi Iwai2011-05-031-4/+4
| | | | | | Use snd_printdd() for less important debug messages. Signed-off-by: Takashi Iwai <tiwai@suse.de>
* ALSA: Add the driver for Digigram Lola PCI-e boardsTakashi Iwai2011-05-031-0/+731
Added a new driver for supporting Digigram Lola PCI-e boards. Lola has a similar h/w design like HD-audio but with extended verbs. Thus the driver is written similarly like HD-audio driver in the bus part. The codec part is rather written in a fixed way specific to the Lola board because of the verb incompatibility. The driver provides basic PCM, supporting multi-streams and mixing. Signed-off-by: Takashi Iwai <tiwai@suse.de>
OpenPOWER on IntegriCloud