summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrunge <runge>2005-05-03 22:37:51 +0000
committerrunge <runge>2005-05-03 22:37:51 +0000
commit1bb36df34ea25a3379b5232154a55e4da489ab60 (patch)
treedbf17e80285abe351d7a8d8ef62d1ee58929931b /configure.ac
parentb0daa444cc2fdda15b8b82497d17f80e7d75f8ad (diff)
downloadlibvncserver-1bb36df34ea25a3379b5232154a55e4da489ab60.zip
libvncserver-1bb36df34ea25a3379b5232154a55e4da489ab60.tar.gz
libvncserver/main.c: fix memory leak in rfbDoCopyRect/rfbScheduleCopyRect; configure.ac tweaks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 16 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 9f2299d..92601e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,10 +137,10 @@ fi
AC_SUBST(X_LIBS)
AM_CONDITIONAL(HAVE_X, test $HAVE_X != "false")
-if test "$PACKAGE_NAME" = "x11vnc" -a $HAVE_X = "false"; then
+if test "$PACKAGE_NAME" = "x11vnc" -a "x$HAVE_X" = "xfalse"; then
AC_MSG_ERROR([
==========================================================================
-a working X window system build environment is required to build x11vnc.
+A working X window system build environment is required to build x11vnc.
Make sure any required X development packages are installed. If they are
installed in non-standard locations, one can use the --x-includes=DIR
and --x-libraries=DIR configure options or set the CPPFLAGS and LDFLAGS
@@ -190,11 +190,13 @@ if test "x$with_jpeg" != "xno"; then
if test "$PACKAGE_NAME" = "x11vnc"; then
if test "x$HAVE_JPEGLIB_H" != "xtrue"; then
AC_MSG_WARN([
-libjpeg compression library was not found: this may lead to reduced performance
-especially over slow links. If libjpeg is in a non-standard location
-use --with-jpeg=DIR to indicate the header file is in DIR/include/jpeglib.h
-and the library in DIR/lib/libjpeg.a. A copy of libjpeg may be obtained
-from: ftp://ftp.uu.net/graphics/jpeg/
+==========================================================================
+The libjpeg compression library was not found: this may lead to reduced
+performance, especially over slow links. If libjpeg is in a non-standard
+location use --with-jpeg=DIR to indicate the header file is in
+DIR/include/jpeglib.h and the library in DIR/lib/libjpeg.a. A copy of
+libjpeg may be obtained from: ftp://ftp.uu.net/graphics/jpeg/
+==========================================================================
])
fi
fi
@@ -231,11 +233,13 @@ if test "x$with_zlib" != "xno" -a "x$with_libz" != "xno"; then
if test "$PACKAGE_NAME" = "x11vnc"; then
if test "x$HAVE_ZLIB_H" != "xtrue"; then
AC_MSG_WARN([
-libz compression library was not found: this may lead to reduced performance,
-especially over slow links. If libz is in a non-standard location
-use --with-zlib=DIR to indicate the header file is in DIR/include/zlib.h
-and the library in DIR/lib/libz.a. A copy of libz may be obtained
-from: http://www.gzip.org/zlib/
+==========================================================================
+The libz compression library was not found: this may lead to reduced
+performance, especially over slow links. If libz is in a non-standard
+location use --with-zlib=DIR to indicate the header file is in
+DIR/include/zlib.h and the library in DIR/lib/libz.a. A copy of
+libz may be obtained from: http://www.gzip.org/zlib/
+==========================================================================
])
fi
fi
OpenPOWER on IntegriCloud