summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authordscho <dscho>2005-09-28 16:51:50 +0000
committerdscho <dscho>2005-09-28 16:51:50 +0000
commit0a909fde7a283fb22c22bbdbc16bcf4c0fe391ec (patch)
tree9de5c473941fc3c2525a7cbc67fc416cee11efc0 /configure.ac
parent93be927b1c1c74bc4da6f6d5978ba8e6e52f3cc2 (diff)
downloadlibvncserver-0a909fde7a283fb22c22bbdbc16bcf4c0fe391ec.zip
libvncserver-0a909fde7a283fb22c22bbdbc16bcf4c0fe391ec.tar.gz
This monster commit contains support for TightVNC's file transfer protocol.
Thank you very much, Rohit!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f134de5..84079ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,14 @@ AC_PATH_PROG([AR], [ar], [/usr/bin/ar],
[$PATH:/usr/ccs/bin])
# Options
+AH_TEMPLATE(WITH_TIGHTVNC_FILETRANSFER, [Disable TightVNCFileTransfer protocol])
+AC_ARG_WITH(tightvnc-filetransfer,
+ [ --without-filetransfer disable TightVNC file transfer protocol],
+ , [ with_tightvnc_filetransfer=yes ])
+if test "x$with_tightvnc_filetransfer" == "xyes"; then
+ AC_DEFINE(WITH_TIGHTVNC_FILETRANSFER)
+fi
+AM_CONDITIONAL(WITH_TIGHTVNC_FILETRANSFER, test "$with_tightvnc_filetransfer" == "yes")
AH_TEMPLATE(BACKCHANNEL, [Enable BackChannel communication])
AC_ARG_WITH(backchannel,
[ --without-backchannel disable backchannel method],
OpenPOWER on IntegriCloud