summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..aa4c3c3
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,34 @@
+
+
+lib_LTLIBRARIES = libffts.la
+
+libffts_la_SOURCES = ffts.c ffts_small.c ffts_nd.c ffts_real.c ffts_real_nd.c patterns.c
+libffts_la_SOURCES += codegen.h codegen_arm.h codegen_sse.h ffts.h ffts_nd.h ffts_real.h ffts_real_nd.h ffts_small.h ffts_static.h macros-alpha.h macros-altivec.h macros-neon.h macros-sse.h macros.h neon.h neon_float.h patterns.h types.h vfp.h
+
+if DYNAMIC_DISABLED
+libffts_la_SOURCES += ffts_static.c
+else
+libffts_la_SOURCES += codegen.c
+endif
+
+libffts_includedir=$(includedir)/ffts
+libffts_include_HEADERS = ../include/ffts.h
+
+
+if HAVE_VFP
+libffts_la_SOURCES += vfp.s
+else
+if HAVE_NEON
+
+libffts_la_SOURCES += neon.s
+
+if DYNAMIC_DISABLED
+libffts_la_SOURCES += neon_static_f.s neon_static_i.s
+endif
+
+else
+if HAVE_SSE
+libffts_la_SOURCES += sse.s
+endif
+endif
+endif
OpenPOWER on IntegriCloud