summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony Blake <anthonix@me.com>2012-08-09 13:36:45 +1200
committerAnthony Blake <anthonix@me.com>2012-08-09 13:36:45 +1200
commit829c8fbb2fe38c0f5c45d6f081c53dde73dc605d (patch)
tree50a3148093431a325aaf876e177524b1883223de /configure.ac
parent9993b4b77bd21971c2e1a43dbb45567b692698c7 (diff)
downloadffts-829c8fbb2fe38c0f5c45d6f081c53dde73dc605d.zip
ffts-829c8fbb2fe38c0f5c45d6f081c53dde73dc605d.tar.gz
Pre- dynamic code generation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 06cb913..25d6c71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,7 @@ AC_PROG_CC
#SFFT_CFLAGS="$CFLAGS"
#SFFT_CC="$CC"
+SIMD=sse
AC_ARG_ENABLE(single, [AC_HELP_STRING([--enable-single],[compile single-precision library])], sfft_single=$enableval, sfft_single=no)
if test "$sfft_single" = "yes"; then
@@ -29,6 +30,16 @@ if test "$sfft_single" = "no"; then
AC_DEFINE(FFTS_PREC_SINGLE,0,[Define to FFT in single precision.])
fi
+AC_ARG_ENABLE(neon, [AC_HELP_STRING([--enable-neon],[enable NEON extensions])], have_neon=$enableval, have_neon=no)
+if test "$have_neon" = "yes"; then
+ if test "$SIMD" != "sse"; then
+ AC_MSG_ERROR([conflicting SIMD extensisons specified])
+ fi
+ AC_DEFINE(HAVE_NEON,1,[Define to FFT with ARM NEON.])
+fi
+AM_CONDITIONAL(HAVE_NEON, test "$have_neon" = "yes")
+
+
#if test "$ord_sr" = "no"; then
# AC_DEFINE(SFFT_ORD_SR,0,[Define to enable ordinary split radix.])
#fi
@@ -49,7 +60,7 @@ AC_TYPE_SIZE_T
AC_TYPE_UINT64_T
# Checks for library functions.
-AC_FUNC_MALLOC
+#AC_FUNC_MALLOC
AC_CHECK_FUNCS([gettimeofday pow])
OpenPOWER on IntegriCloud