summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony Blake <anthonix@me.com>2013-04-22 16:45:17 +1200
committerAnthony Blake <anthonix@me.com>2013-04-22 16:45:17 +1200
commit7b3907cff81fb82380787e63e4304fb8af807c0c (patch)
tree11ae035cd02aab22e1a4069737fb6f422a7531eb /configure.ac
parenta45464980b8de7faef21eb46479f7e09fd056441 (diff)
downloadffts-7b3907cff81fb82380787e63e4304fb8af807c0c.zip
ffts-7b3907cff81fb82380787e63e4304fb8af807c0c.tar.gz
Fixed up the smaller VFP transforms. Inverse VFP and real/nd VFP still not working yet.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 15 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index b60aa76..b4eb280 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,26 +34,27 @@ if test "$sfft_single" = "no"; then
AC_DEFINE(FFTS_PREC_SINGLE,0,[Define to FFT in single precision.])
fi
-AC_ARG_ENABLE(sse, [AC_HELP_STRING([--enable-sse],[enable SSE extensions])], have_sse=$enableval, have_sse=yes)
+AC_ARG_ENABLE(sse, [AC_HELP_STRING([--enable-sse],[enable SSE extensions])], have_sse=$enableval, have_sse=no)
if test "$have_sse" = "yes"; then
SIMD=sse
+ AC_DEFINE(HAVE_SSE,1,[Define to FFT with SSE.])
fi
AM_CONDITIONAL(HAVE_SSE, test "$have_sse" = "yes")
AC_ARG_ENABLE(neon, [AC_HELP_STRING([--enable-neon],[enable NEON extensions])], have_neon=$enableval, have_neon=no)
if test "$have_neon" = "yes"; then
- if test "$SIMD" != "sse"; then
- AC_MSG_ERROR([conflicting SIMD extensisons specified])
- fi
+# if test "$SIMD" != "sse"; then
+# AC_MSG_ERROR([conflicting SIMD extensisons specified])
+# fi
AC_DEFINE(HAVE_NEON,1,[Define to FFT with ARM NEON.])
fi
AM_CONDITIONAL(HAVE_NEON, test "$have_neon" = "yes")
AC_ARG_ENABLE(vfp, [AC_HELP_STRING([--enable-vfp],[enable VFP extensions])], have_vfp=$enableval, have_vfp=no)
if test "$have_vfp" = "yes"; then
- if test "$SIMD" != "sse"; then
- AC_MSG_ERROR([conflicting SIMD extensisons specified])
- fi
+# if test "$SIMD" != "sse"; then
+# AC_MSG_ERROR([conflicting SIMD extensisons specified])
+# fi
AC_DEFINE(HAVE_VFP,1,[Define to FFT with ARM VFP.])
fi
AM_CONDITIONAL(HAVE_VFP, test "$have_vfp" = "yes")
@@ -62,8 +63,13 @@ AM_CONDITIONAL(HAVE_VFP, test "$have_vfp" = "yes")
AC_MSG_NOTICE([host is "${host}"])
case "${host}" in
arm* )
- CFLAGS="$CFLAGS -mfloat-abi=softfp -mfpu=neon -std=c99"
- CCASFLAGS="$CCASFLAGS -mfloat-abi=softfp -mfpu=neon "
+ if test "$have_vfp" = "yes"; then
+ CFLAGS="$CFLAGS -mfloat-abi=softfp -mfpu=vfp -std=c99"
+ CCASFLAGS="$CCASFLAGS -mfloat-abi=softfp -mfpu=vfp "
+ else
+ CFLAGS="$CFLAGS -mfloat-abi=softfp -mfpu=neon -std=c99"
+ CCASFLAGS="$CCASFLAGS -mfloat-abi=softfp -mfpu=neon "
+ fi
;;
*)
;;
OpenPOWER on IntegriCloud