summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony Blake <anthonix@me.com>2012-08-29 18:08:30 +1200
committerAnthony Blake <anthonix@me.com>2012-08-29 18:08:30 +1200
commit5e4a32240e9ed9cb03ef51d2344ec80c615489cb (patch)
treeae0fea8ad5906bad0a2393868eeb10b0019815f9 /configure.ac
parent625f46968820cb98391d67782a9deac4504e289a (diff)
downloadffts-5e4a32240e9ed9cb03ef51d2344ec80c615489cb.zip
ffts-5e4a32240e9ed9cb03ef51d2344ec80c615489cb.tar.gz
SSE LEAF EE works
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 25d6c71..df2742c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,8 @@ AC_CONFIG_HEADERS([config.h])
AC_PROG_CXX
AC_PROG_CC
#AX_COMPILER_VENDOR
-
+LT_INIT([disable-shared])
+AM_PROG_AS
#CXX="clang++"
#CXXFLAGS="$CXXFLAGS -stdlib=libc++"
@@ -20,8 +21,6 @@ AC_PROG_CC
#SFFT_CFLAGS="$CFLAGS"
#SFFT_CC="$CC"
-SIMD=sse
-
AC_ARG_ENABLE(single, [AC_HELP_STRING([--enable-single],[compile single-precision library])], sfft_single=$enableval, sfft_single=no)
if test "$sfft_single" = "yes"; then
AC_DEFINE(FFTS_PREC_SINGLE,1,[Define to FFT in single precision.])
@@ -30,6 +29,12 @@ if test "$sfft_single" = "no"; then
AC_DEFINE(FFTS_PREC_SINGLE,0,[Define to FFT in single precision.])
fi
+AC_ARG_ENABLE(sse, [AC_HELP_STRING([--enable-sse],[enable SSE extensions])], have_sse=$enableval, have_sse=yes)
+if test "$have_sse" = "yes"; then
+ SIMD=sse
+fi
+AM_CONDITIONAL(HAVE_SSE, test "$have_sse" = "yes")
+
AC_ARG_ENABLE(neon, [AC_HELP_STRING([--enable-neon],[enable NEON extensions])], have_neon=$enableval, have_neon=no)
if test "$have_neon" = "yes"; then
if test "$SIMD" != "sse"; then
OpenPOWER on IntegriCloud