summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony Blake <anthonix@me.com>2012-10-11 17:53:46 +1300
committerAnthony Blake <anthonix@me.com>2012-10-11 17:53:46 +1300
commit11c42fab7cda9d63f763962970fbac754b2192de (patch)
treea5b766201fab4afa456ffcda4d8db1fa9a62fddb /configure.ac
parent54a23010b42e55641fca1aeb30261cc51db91881 (diff)
downloadffts-11c42fab7cda9d63f763962970fbac754b2192de.zip
ffts-11c42fab7cda9d63f763962970fbac754b2192de.tar.gz
Builds and runs on Android/ARM
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index df2742c..dfd476f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,7 +44,16 @@ if test "$have_neon" = "yes"; then
fi
AM_CONDITIONAL(HAVE_NEON, test "$have_neon" = "yes")
-
+#AC_CANONICAL_HOST
+AC_MSG_NOTICE([host is "${host}"])
+case "${host}" in
+ arm* )
+ CFLAGS="$CFLAGS -mfloat-abi=softfp -mfpu=neon -std=c99"
+ CCASFLAGS="$CCASFLAGS -mfloat-abi=softfp -mfpu=neon "
+ ;;
+ *)
+ ;;
+esac
#if test "$ord_sr" = "no"; then
# AC_DEFINE(SFFT_ORD_SR,0,[Define to enable ordinary split radix.])
#fi
@@ -63,7 +72,10 @@ AC_TYPE_INT32_T
AC_C_RESTRICT
AC_TYPE_SIZE_T
AC_TYPE_UINT64_T
-
+AC_PROG_CC_STDC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_LIBTOOL
# Checks for library functions.
#AC_FUNC_MALLOC
AC_CHECK_FUNCS([gettimeofday pow])
@@ -72,5 +84,6 @@ AC_CHECK_FUNCS([gettimeofday pow])
AC_CONFIG_FILES([Makefile
src/Makefile
tests/Makefile
+ ffts.pc
])
AC_OUTPUT
OpenPOWER on IntegriCloud