summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJukka Ojanen <jukka.ojanen@linkotec.net>2015-03-11 18:50:27 +0200
committerJukka Ojanen <jukka.ojanen@linkotec.net>2015-03-11 18:50:27 +0200
commit69b7770ec32dbda9d4fcca198e830f84256640fc (patch)
tree80672e6b6a9dce5e7cfe5b1363d5f50510a69c00 /CMakeLists.txt
parent72fc3742112c384a2af02d0b51c98cedccc7165f (diff)
downloadffts-69b7770ec32dbda9d4fcca198e830f84256640fc.zip
ffts-69b7770ec32dbda9d4fcca198e830f84256640fc.tar.gz
Try to execute detection quietly without messages
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fa2a3f..12b3bf8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,8 +70,12 @@ if(NOT CMAKE_CROSSCOMPILING)
# Determinate what floating-point hardware
# (or hardware emulation) is available
#
- # Test compilation with -mfpu=neon
cmake_push_check_state()
+
+ # Try to execute quietly without messages
+ set(CMAKE_REQUIRED_QUIET 1)
+
+ # Test compilation with -mfpu=neon
set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -mfpu=neon")
check_symbol_exists(exit stdlib.h NEON_AVAILABLE)
if(NOT NEON_AVAILABLE)
OpenPOWER on IntegriCloud