summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJukka Ojanen <jukka.ojanen@linkotec.net>2014-11-24 12:39:55 +0200
committerJukka Ojanen <jukka.ojanen@linkotec.net>2014-11-24 12:39:55 +0200
commit06d9dc191a2d5ffcebeecaebd1d082c536fb9a8a (patch)
treecc319d2e9547bd31df2bc2677295638ee4db77af /CMakeLists.txt
parentab587e6f33d415334ed706f6b1e021564aee8feb (diff)
downloadffts-06d9dc191a2d5ffcebeecaebd1d082c536fb9a8a.zip
ffts-06d9dc191a2d5ffcebeecaebd1d082c536fb9a8a.tar.gz
Update README, build for 32 bit and 64 bit Windows are now supported
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2cfe43d..16ca9af 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,17 +54,17 @@ if(MSVC)
add_definitions(-D_USE_MATH_DEFINES)
elseif(CMAKE_COMPILER_IS_GNUCC)
include(CheckLibraryExists)
-
+
# enable all warnings
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra")
-
+
# some systems need libm for some of the math functions to work
check_library_exists(m pow "" HAVE_LIBM)
if(HAVE_LIBM)
list(APPEND CMAKE_REQUIRED_LIBRARIES m)
list(APPEND FFTS_EXTRA_LIBRARIES m)
endif(HAVE_LIBM)
-
+
if(HAVE_XMMINTRIN_H)
add_definitions(-msse)
endif(HAVE_XMMINTRIN_H)
@@ -129,13 +129,13 @@ elseif(HAVE_XMMINTRIN_H)
list(APPEND FFTS_SOURCES
src/codegen_sse.h
)
-
+
if(MSVC)
if(NOT ENABLE_RUNTIME_DYNAMIC_CODE)
# YASM supports x86 GAS syntax
- set(CMAKE_ASM-ATT_COMPILER yasm)
+ set(CMAKE_ASM-ATT_COMPILER yasm)
enable_language(ASM-ATT)
-
+
if(CMAKE_ASM-ATT_COMPILER_WORKS)
add_custom_command(
OUTPUT sse_win64.obj
@@ -146,7 +146,7 @@ elseif(HAVE_XMMINTRIN_H)
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
COMMENT "Generating sse_win64.obj"
)
-
+
list(APPEND FFTS_SOURCES
${CMAKE_CURRENT_BINARY_DIR}/sse_win64.obj
src/sse_win64.s
@@ -169,7 +169,7 @@ elseif(HAVE_XMMINTRIN_H)
message(WARNING "Dynamic code is only supported with x64, disabling dynamic code.")
set(DISABLE_DYNAMIC_CODE ON)
endif(CMAKE_SIZEOF_VOID_P EQUAL 8)
- endif(NOT DISABLE_DYNAMIC_CODE)
+ endif(NOT DISABLE_DYNAMIC_CODE)
endif(ENABLE_NEON)
if(DISABLE_DYNAMIC_CODE)
OpenPOWER on IntegriCloud