summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..2e9656a
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,44 @@
+AUTOMAKE_OPTIONS = foreign dist-tarZ
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = tinySAK \
+ tinyNET \
+ tinyHTTP \
+ tinyXCAP \
+ tinyIPSec \
+ tinySMS \
+ tinySIGCOMP \
+ tinySDP \
+ tinyBFCP \
+ tinyMSRP \
+ tinyMEDIA \
+ tinyRTP \
+ tinyDAV \
+ tinySIP \
+ \
+ bindings
+
+if TARGET_OS_IS_ANDROID
+SUBDIRS += plugins/audio_opensles
+endif
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = doubango.pc
+
+
+if CROSS_COMPILING
+install-data-hook:
+ echo "Cross-compilation is active. Do not run ldconfig";
+else
+install-data-hook:
+ $(MKDIR_P) $(DESTDIR)/etc/ld.so.conf.d
+ echo "$(libdir)" > $(DESTDIR)/etc/ld.so.conf.d/doubango.conf
+ ldconfig
+endif
+
+if CROSS_COMPILING
+ echo "Cross-compilation is active. Do not remove libs";
+else
+uninstall-hook:
+ rm -f $(DESTDIR)/etc/ld.so.conf.d/doubango.conf
+endif \ No newline at end of file
OpenPOWER on IntegriCloud