summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb b/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb
new file mode 100644
index 0000000..f67e060
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb
@@ -0,0 +1,42 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "virtual/libx11 libxext libxrender startup-notification expat gconf pango libxdamage libxcomposite gtk+"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r4"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager-2;proto=http \
+ "
+
+S = "${WORKDIR}/matchbox-window-manager-2"
+
+inherit autotools pkgconfig update-alternatives
+
+# Change this to x-session-manager->matchbox-session and put in
+# matchbox-session, then change this to x-window-manager to
+# matchbox-window-manager-2.
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+PACKAGES =+ "libmatchbox2"
+
+FILES_libmatchbox2 = "${libdir}/*${SOLIBS}"
+
+FILES_${PN} += "${datadir}/matchbox-2 \
+ ${sysconfdir}/matchbox-2 \
+ ${datadir}/themes/*"
+
+EXTRA_OECONF = "--enable-debug \
+ --enable-simple-manager \
+ --enable-compositing-manager \
+ --enable-libmatchbox \
+ --enable-png-theme \
+ "
+
+do_install_append () {
+ cd ${D}${bindir}
+ ln -s matchbox-window-manager-2-simple matchbox-window-manager
+}
OpenPOWER on IntegriCloud