summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-gst_0.10.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-gst_0.10.22.bb')
-rw-r--r--meta/recipes-devtools/python/python-gst_0.10.22.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-gst_0.10.22.bb b/meta/recipes-devtools/python/python-gst_0.10.22.bb
index a551adb..2a5f2b3 100644
--- a/meta/recipes-devtools/python/python-gst_0.10.22.bb
+++ b/meta/recipes-devtools/python/python-gst_0.10.22.bb
@@ -21,3 +21,9 @@ EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
FILES_${PN} += "${datadir}/gst-python"
FILES_${PN}-dev += "${datadir}/gst-python/0.10/defs"
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/ ${libdir}/gstreamer-0.10/.debug/"
+
+do_configure_prepend() {
+ if [ `find ${STAGING_LIBDIR} -name libpython*.so` ]; then
+ ln -sf ${STAGING_LIBDIR}/libpython*.so `find ${STAGING_LIBDIR} -name libpython*.a -exec dirname {} \;`
+ fi
+}
OpenPOWER on IntegriCloud