summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool_2.4.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool_2.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool_2.4.bb b/meta/recipes-devtools/libtool/libtool_2.4.bb
new file mode 100644
index 0000000..cca3b1e
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool_2.4.bb
@@ -0,0 +1,33 @@
+require libtool.inc
+DEPENDS = "libtool-native"
+
+PR = "r0"
+
+PACKAGES =+ "libltdl libltdl-dev libltdl-dbg"
+FILES_${PN} += "${datadir}/aclocal*"
+FILES_libltdl = "${libdir}/libltdl.so.*"
+FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
+FILES_libltdl-dbg = "${libdir}/.debug/"
+
+inherit autotools
+
+EXTRA_AUTORECONF = "--exclude=libtoolize"
+
+do_compile_prepend () {
+ # Sometimes this file doesn't get rebuilt, force the issue
+ rm -f ${S}/libltdl/config/ltmain.sh
+ make libltdl/config/ltmain.sh
+}
+
+#
+# We want the results of libtool-cross preserved - don't stage anything ourselves.
+#
+SYSROOT_PREPROCESS_FUNCS += "libtool_sysroot_preprocess"
+
+libtool_sysroot_preprocess () {
+ if [ "${PN}" == "libtool" ]; then
+ rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${bindir}/*
+ rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/aclocal/*
+ rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/libtool/config/*
+ fi
+}
OpenPOWER on IntegriCloud