summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-nativesdk_2.2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-nativesdk_2.2.10.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-nativesdk_2.2.10.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-nativesdk_2.2.10.bb b/meta/recipes-devtools/libtool/libtool-nativesdk_2.2.10.bb
new file mode 100644
index 0000000..e972d9e
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-nativesdk_2.2.10.bb
@@ -0,0 +1,27 @@
+require libtool_${PV}.bb
+
+PR = "r1"
+SRC_URI_append = " file://cross_compile.patch \
+ file://prefix.patch "
+
+inherit nativesdk
+
+do_configure_prepend () {
+ # Remove any existing libtool m4 since old stale versions would break
+ # any upgrade
+ rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
+ rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/
+}
+
+SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess"
+
+libtoolnativesdk_sysroot_preprocess () {
+ install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
+ install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
+}
OpenPOWER on IntegriCloud