summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.17.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.17.3.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.17.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.17.3.bb b/meta/recipes-devtools/autogen/autogen-native_5.17.3.bb
new file mode 100644
index 0000000..b101966
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.17.3.bb
@@ -0,0 +1,34 @@
+SUMMARY = "AutoGen is a tool to manage programs that contain large amounts of repetitious text."
+DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
+ maintenance of programs that contain large amounts of repetitious text.\
+ It is especially valuable in programs that have several blocks of text\
+ that must be kept synchronized."
+HOMEPAGE = "http://www.gnu.org/software/autogen/"
+SECTION = "devel"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
+ file://guile.patch"
+
+SRC_URI[md5sum] = "2d14ced1c28f71e61bb7c58e93317a40"
+SRC_URI[sha256sum] = "2f795c224fac899ec3a801a9a32aad2a8104fe926dcc1994cc0797f9a3f4e97d"
+
+DEPENDS = "guile-native libtool-native libxml2-native"
+RDEPENDS = "automake pkgconfig"
+
+inherit autotools native
+
+# Following line will be needed for the non-native target recipe.
+#CFLAGS += "-L${STAGING_LIBDIR} -lguile-2.0 -lgc -pthread -I${STAGING_INCDIR}/guile/2.0 -I${STAGING_INCDIR}"
+
+# autogen-native links against libguile which may have been relocated with sstate
+# these environment variables ensure there isn't a relocation issue
+export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
+export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
+
+do_install_append () {
+ create_wrapper ${D}/${bindir}/autogen \
+ GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
+ GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
+}
OpenPOWER on IntegriCloud