summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/console-tools/console-tools_0.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/console-tools/console-tools_0.3.2.bb')
-rw-r--r--meta/recipes-core/console-tools/console-tools_0.3.2.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-core/console-tools/console-tools_0.3.2.bb b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
new file mode 100644
index 0000000..3c5067f
--- /dev/null
+++ b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
@@ -0,0 +1,49 @@
+SECTION = "base"
+LICENSE = "GPL"
+DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
+DEPENDS = "gettext"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
+ file://codepage.patch;patch=1 \
+ file://configure.patch;patch=1 \
+ file://compile.patch;patch=1 \
+ file://kbdrate.patch;patch=1 \
+ file://uclibc-fileno.patch;patch=1 \
+ file://config/*.m4"
+
+export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \
+ examples po intl compat"
+
+acpaths = "-I config"
+do_configure_prepend () {
+ mkdir -p config
+ cp ${WORKDIR}/config/*.m4 config/
+}
+
+do_compile () {
+ oe_runmake -C lib
+ oe_runmake 'SUBDIRS=${SUBDIRS}'
+}
+
+inherit autotools
+
+do_install () {
+ autotools_do_install
+ mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
+ mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
+ mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
+ update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
+ update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove chvt chvt.${PN}
+ update-alternatives --remove deallocvt deallocvt.${PN}
+ update-alternatives --remove openvt openvt.${PN}
+}
+
OpenPOWER on IntegriCloud