summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/conf/bblayers.conf.sample8
-rw-r--r--meta-yocto/conf/distro/poky-bleeding.conf8
-rw-r--r--meta-yocto/conf/distro/poky-lsb.conf9
-rw-r--r--meta-yocto/conf/distro/poky.conf167
-rw-r--r--meta-yocto/conf/local.conf.sample219
-rw-r--r--meta-yocto/conf/machine/atom-pc.conf46
-rw-r--r--meta-yocto/conf/machine/beagleboard.conf37
-rw-r--r--meta-yocto/conf/machine/mpc8315e-rdb.conf20
-rw-r--r--meta-yocto/conf/machine/routerstationpro.conf24
-rw-r--r--meta-yocto/conf/site.conf.sample40
10 files changed, 578 insertions, 0 deletions
diff --git a/meta-yocto/conf/bblayers.conf.sample b/meta-yocto/conf/bblayers.conf.sample
new file mode 100644
index 0000000..b2f37c0
--- /dev/null
+++ b/meta-yocto/conf/bblayers.conf.sample
@@ -0,0 +1,8 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "4"
+
+BBFILES ?= ""
+BBLAYERS = " \
+ ##POKYBASE##/meta \
+ "
diff --git a/meta-yocto/conf/distro/poky-bleeding.conf b/meta-yocto/conf/distro/poky-bleeding.conf
new file mode 100644
index 0000000..328acfe
--- /dev/null
+++ b/meta-yocto/conf/distro/poky-bleeding.conf
@@ -0,0 +1,8 @@
+PREFERRED_VERSION_glib-2.0 ?= "2.17.4"
+PREFERRED_VERSION_glib-2.0-native ?= "2.17.4"
+PREFERRED_VERSION_atk ?= "1.22.0"
+PREFERRED_VERSION_pango ?= "1.21.2"
+PREFERRED_VERSION_gtk+ ?= "2.13.3"
+
+require conf/distro/include/poky-floating-revisions.inc
+require conf/distro/poky.conf
diff --git a/meta-yocto/conf/distro/poky-lsb.conf b/meta-yocto/conf/distro/poky-lsb.conf
new file mode 100644
index 0000000..749c858
--- /dev/null
+++ b/meta-yocto/conf/distro/poky-lsb.conf
@@ -0,0 +1,9 @@
+require conf/distro/poky.conf
+
+DISTRO = "poky-lsb"
+DISTROOVERRIDES = "poky:poky-lsb"
+
+DISTRO_FEATURES += "pam"
+PREFERRED_PROVIDER_virtual/libx11 = "libx11"
+
+
diff --git a/meta-yocto/conf/distro/poky.conf b/meta-yocto/conf/distro/poky.conf
new file mode 100644
index 0000000..71e40de
--- /dev/null
+++ b/meta-yocto/conf/distro/poky.conf
@@ -0,0 +1,167 @@
+#@TYPE: Distribution#@NAME: Poky
+#@DESCRIPTION: Distribution configuration for the Yocto Project build by Poky
+
+DISTRO = "poky"
+DISTRO_NAME = "Yocto (Built by Poky 4.0)"
+DISTRO_VERSION = "0.9+snapshot-${DATE}"
+SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
+
+MAINTAINER = "Poky <poky@yoctoproject.org>"
+
+USER_CLASSES ?= ""
+
+PACKAGE_CLASSES ?= "package_ipk"
+INHERIT_INSANE ?= "insane"
+INHERIT += "${PACKAGE_CLASSES} ${USER_CLASSES} debian devshell ${INHERIT_INSANE} sstate license"
+# For some reason, this doesn't work
+# TARGET_OS ?= "linux"
+# TARGET_VENDOR ?= "-poky"
+# Set by POKYMODE instead
+TARGET_OS = "linux"
+TARGET_FPU_arm ?= "soft"
+TARGET_FPU_armeb ?= "soft"
+TARGET_FPU_nokia800 = "hard"
+
+TARGET_LINK_HASH_STYLE ?= "${@['-Wl,--hash-style=gnu',''][bb.data.getVar('TARGET_ARCH', d, True) in ['mips', 'mipsel', 'mips64', 'mips64el']]}"
+
+QA_LOGFILE = "${TMPDIR}/qa.log"
+
+IMAGE_ROOTFS_SIZE_ext2 ?= "131072"
+
+#IPK_FEED_URIS += " \
+# upgrades##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/upgrades/ \
+#upgrades-${MACHINE}##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/upgrades/${MACHINE} \
+# machine##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/machine/${MACHINE} \
+# base##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/base/ \
+# libs##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/libs/ \
+# console##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/console \
+# devel##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/devel"
+
+#RPM_FEED_URIS += " \
+# upgrades##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/upgrades/ \
+#upgrades-${MACHINE}##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/upgrades/${MACHINE} \
+# machine##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/machine/${MACHINE} \
+# base##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/base/ \
+# libs##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/libs/ \
+# console##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/console \
+# devel##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/devel"
+
+OEINCLUDELOGS = "yes"
+KERNEL_CONSOLE = "ttyS0"
+#DEBUG_OPTIMIZATION = "-O -g3"
+#DEBUG_BUILD = "1"
+#INHIBIT_PACKAGE_STRIP = "1"
+
+# Default to TARGETOS values for EABI on arm
+GLIBCTARGETOS = "linux${@['','-gnueabi'][bb.data.getVar('TARGET_ARCH',d,1) in ['arm', 'armeb']]}"
+UCLIBCTARGETOS = "linux${@['-uclibc','-uclibcgnueabi'][bb.data.getVar('TARGET_ARCH',d,1) in ['arm', 'armeb']]}"
+
+POKYMODE ?= "default"
+require conf/distro/include/poky-${POKYMODE}.inc
+
+POKYLIBC ?= "eglibc"
+require conf/distro/include/poky-${POKYLIBC}.inc
+
+SDK_NAME = "${DISTRO}-${POKYLIBC}-${SDK_ARCH}-${TARGET_ARCH}"
+SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}"
+
+CACHE = "${TMPDIR}/cache/${POKYMODE}-${POKYLIBC}${@['', '/' + str(bb.data.getVar('MACHINE', d, 1))][bool(bb.data.getVar('MACHINE', d, 1))]}${@['', '/' + str(bb.data.getVar('SDKMACHINE', d, 1))][bool(bb.data.getVar('SDKMACHINE', d, 1))]}"
+
+#
+# Preferred providers:
+#
+
+# Virtuals:
+PREFERRED_PROVIDER_virtual/db ?= "db"
+PREFERRED_PROVIDER_virtual/db-native ?= "db-native"
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86"
+PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
+PREFERRED_PROVIDER_virtual/libgl ?= "mesa-xlib"
+PREFERRED_PROVIDER_virtual/update-alternatives ?= "update-alternatives-cworth"
+PREFERRED_PROVIDER_virtual/update-alternatives-native ?= "opkg-native"
+PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
+PREFERRED_PROVIDER_xf86-video-intel ?= "xf86-video-intel"
+
+VIRTUAL-RUNTIME_update-alternatives ?= "update-alternatives-cworth"
+
+# Others:
+PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers"
+PREFERRED_PROVIDER_linux-libc-headers-nativesdk ?= "linux-libc-headers-nativesdk"
+PREFERRED_PROVIDER_libgcc ?= "libgcc"
+PREFERRED_PROVIDER_libgcc-nativesdk ?= "libgcc-nativesdk"
+PREFERRED_PROVIDER_dbus-glib ?= "dbus-glib"
+PREFERRED_PROVIDER_dbus-glib-native ?= "dbus-glib-native"
+PREFERRED_PROVIDER_gconf ?= "gconf-dbus"
+PREFERRED_PROVIDER_matchbox-panel ?= "matchbox-panel-2"
+PREFERRED_PROVIDER_opkg ?= "opkg"
+PREFERRED_PROVIDER_opkg-native ?= "opkg-native"
+PREFERRED_PROVIDER_opkg-nativesdk ?= "opkg-nativesdk"
+
+PREFERRED_PROVIDER_gdk-pixbuf ?= "gdk-pixbuf"
+
+require conf/distro/include/poky-fixed-revisions.inc
+require conf/distro/include/preferred-xorg-versions.inc
+
+PCMCIA_MANAGER ?= "pcmciautils"
+
+#IMAGE_LINGUAS ?= "en-gb en-us"
+#LIMIT_BUILT_LOCALES ?= "en_GB en_US"
+IMAGE_LINGUAS ?= "en-us en-gb"
+LIMIT_BUILT_LOCALES ?= "POSIX en_US en_GB"
+ENABLE_BINARY_LOCALE_GENERATION ?= "1"
+LOCALE_UTF8_ONLY = "0"
+
+DISTRO_FEATURES = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost wifi nfs zeroconf pci"
+
+POKY_EXTRA_RDEPENDS = "task-poky-boot"
+POKY_EXTRA_RDEPENDS_qemuarm = "qemu-config"
+POKY_EXTRA_RDEPENDS_qemuarmv6 = "qemu-config"
+POKY_EXTRA_RDEPENDS_qemuarmv7 = "qemu-config"
+POKY_EXTRA_RDEPENDS_qemux86 = "qemu-config"
+POKY_EXTRA_RDEPENDS_qemux86-64 = "qemu-config"
+
+DISTRO_EXTRA_RDEPENDS += "${POKY_EXTRA_RDEPENDS}"
+DISTRO_EXTRA_RRECOMMENDS += "kernel-module-af-packet"
+
+IMAGE_FEATURES ?= ""
+
+EXTRAOPKGCONFIG = "poky-feed-config-opkg"
+
+# This is a list of packages that are used by poky to build the distribution, they are not
+# directly part of the distribution.
+HOSTTOOLS_WHITELIST_GPLv3 ?= ""
+WHITELIST_GPLv3 ?= "less gnome-common"
+LGPLv2_WHITELIST_GPLv3 ?= "libassuan gnutls libtasn1 libidn"
+
+# This is a list of packages that require a commercial license to ship
+# product. If shipped as part of an image these packages may have
+# implications so they are disabled by default
+COMMERCIAL_LICENSE ?= "lame gst-fluendo-mp3 libmad mpeg2dec ffmpeg qmmp"
+COMMERCIAL_AUDIO_PLUGINS ?= ""
+# COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse"
+COMMERCIAL_VIDEO_PLUGINS ?= ""
+# COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse"
+COMMERCIAL_QT ?= ""
+# COMMERCIAL_QT ?= "qmmp"
+# Set of common licenses used for license.bbclass
+COMMON_LICENSE_DIR ??= "${POKYBASE}/meta/files/common-licenses"
+
+BB_GENERATE_MIRROR_TARBALLS ??= "0"
+
+require conf/distro/include/world-broken.inc
+
+PREMIRRORS ?= "\
+bzr://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
+cvs://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
+git://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
+hg://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
+osc://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
+p4://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
+svk://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
+svn://.*/.* http://autobuilder.yoctoproject.org/sources/ \n"
+
+MIRRORS =+ "\
+ftp://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
+http://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
+https://.*/.* http://autobuilder.yoctoproject.org/sources/ \n"
+
diff --git a/meta-yocto/conf/local.conf.sample b/meta-yocto/conf/local.conf.sample
new file mode 100644
index 0000000..434c684
--- /dev/null
+++ b/meta-yocto/conf/local.conf.sample
@@ -0,0 +1,219 @@
+# CONF_VERSION is increased each time build/conf/ changes incompatibly
+CONF_VERSION = "1"
+
+# Uncomment and change to cache the files Poky downloads in an alternative
+# location, default it ${TOPDIR}/downloads
+#DL_DIR ?= "${TOPDIR}/downloads"
+# Uncomment and change to cache Poky's built staging output in an alternative
+# location, default ${TOPDIR}/sstate-cache
+#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
+
+# Uncomment and set to allow bitbake to execute multiple tasks at once.
+# For a quadcore, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
+# be appropriate.
+# BB_NUMBER_THREADS = "4"
+# Also, make can be passed flags so it run parallel threads e.g.:
+# PARALLEL_MAKE = "-j 4"
+
+# Set a default machine to target unless a machine is selected from the
+# lists below.
+MACHINE ??= "qemux86"
+
+# Supported emulation machines
+#MACHINE ?= "qemuarm"
+#MACHINE ?= "qemumips"
+#MACHINE ?= "qemuppc"
+#MACHINE ?= "qemux86"
+#MACHINE ?= "qemux86-64"
+
+# Supported target hardware for demonstration purposes
+#MACHINE ?= "atom-pc"
+#MACHINE ?= "beagleboard"
+#MACHINE ?= "emenlow"
+#MACHINE ?= "mpc8315e-rdb"
+#MACHINE ?= "routerstationpro"
+
+DISTRO ?= "poky"
+# For bleeding edge / experimental / unstable package versions
+# DISTRO ?= "poky-bleeding"
+
+BBMASK = ""
+
+# EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images
+# (Some of these are automatically added to certain image types)
+# "dbg-pkgs" - add -dbg packages for all installed packages
+# (adds symbol information for debugging/profiling)
+# "dev-pkgs" - add -dev packages for all installed packages
+# (useful if you want to develop against libs in the image)
+# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
+# "tools-debug" - add debugging tools (gdb, strace)
+# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
+# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
+# "debug-tweaks" - make an image for suitable of development
+# e.g. ssh root access has a blank password
+# There are other application targets too, see meta/classes/poky-image.bbclass
+# and meta/packages/tasks/task-poky.bb for more details.
+
+EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
+
+# The default IMAGE_FEATURES above are too large for the mx31phy and
+# c700/c750 machines which have limited space. The code below limits
+# the default features for those machines.
+EXTRA_IMAGE_FEATURES_c7x0 = "tools-testapps debug-tweaks"
+EXTRA_IMAGE_FEATURES_mx31phy = "debug-tweaks"
+EXTRA_IMAGE_FEATURES_mx31ads = "tools-testapps debug-tweaks"
+
+# A list of packaging systems used in generated images
+# The first package type listed will be used for rootfs generation
+# include 'package_deb' for debs
+# include 'package_ipk' for ipks
+# include 'package_rpm' for rpms
+#PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
+PACKAGE_CLASSES ?= "package_rpm package_ipk"
+
+# mklibs library size optimization is more useful to smaller images,
+# and less useful for bigger images. Also mklibs library optimization can break the ABI compatibility, so should not be applied to the images which are tobe
+# extended or upgraded later.
+#This enabled mklibs library size optimization just for the specified image.
+#MKLIBS_OPTIMIZED_IMAGES ?= "poky-image-minimal"
+#This enable mklibs library size optimization will be for all the images.
+#MKLIBS_OPTIMIZED_IMAGES ?= "all"
+
+# A list of additional classes to use when building the system
+# include 'image-mklibs' to reduce shared library files size for an image
+# include 'image-prelink' in order to prelink the filesystem image
+# include 'image-swab' to perform host system intrusion detection
+# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
+USER_CLASSES ?= "image-mklibs image-prelink"
+
+# POKYMODE controls the characteristics of the generated packages/images by
+# telling poky which type of toolchain to use.
+#
+# Options include several different EABI combinations and a compatibility
+# mode for the OABI mode poky previously used.
+#
+# The default is "eabi"
+# Use "oabi" for machines with kernels < 2.6.18 on ARM for example.
+# Use "external-MODE" to use the precompiled external toolchains where MODE
+# is the type of external toolchain to use e.g. eabi.
+# POKYMODE = "external-eabi"
+
+# Uncomment this to specify where BitBake should create its temporary files.
+# Note that a full build of everything in OpenEmbedded will take GigaBytes of hard
+# disk space, so make sure to free enough space. The default TMPDIR is
+# <build directory>/tmp
+#TMPDIR = "${POKYBASE}/build/tmp"
+
+# The following are used to control options related to debugging.
+#
+# Uncomment this to change the optimization to make debugging easer, at the
+# possible cost of performance.
+# DEBUG_BUILD = "1"
+#
+# Uncomment this to disable the stripping of the installed binaries
+# INHIBIT_PACKAGE_STRIP = "1"
+#
+# Uncomment this to disable the split of the debug information into -dbg files
+# INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+#
+# When splitting debug information, the following controls the results of the
+# file splitting.
+#
+# .debug (default):
+# When splitting the debug information will be placed into
+# a .debug directory in the same dirname of the binary produced:
+# /bin/foo -> /bin/.debug/foo
+#
+# debug-file-directory:
+# When splitting the debug information will be placed into
+# a central debug-file-directory, /usr/lib/debug:
+# /bin/foo -> /usr/lib/debug/bin/foo.debug
+#
+# Any source code referenced in the debug symbols will be copied
+# and made available within the /usr/src/debug directory
+#
+PACKAGE_DEBUG_SPLIT_STYLE = '.debug'
+# PACKAGE_DEBUG_SPLIT_STYLE = 'debug-file-directory'
+
+# Uncomment these to build a package such that you can use gprof to profile it.
+# NOTE: This will only work with 'linux' targets, not
+# 'linux-uclibc', as uClibc doesn't provide the necessary
+# object files. Also, don't build glibc itself with these
+# flags, or it'll fail to build.
+#
+# PROFILE_OPTIMIZATION = "-pg"
+# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}"
+# LDFLAGS =+ "-pg"
+
+# Uncomment this if you want BitBake to emit debugging output
+# BBDEBUG = "yes"
+# Uncomment this if you want BitBake to emit the log if a build fails.
+BBINCLUDELOGS = "yes"
+
+# Set this if you wish to make pkgconfig libraries from your system available
+# for native builds. Combined with extra ASSUME_PROVIDEDs this can allow
+# native builds of applications like oprofileui-native (unsupported feature).
+#EXTRA_NATIVE_PKGCONFIG_PATH = ":/usr/lib/pkgconfig"
+#ASSUME_PROVIDED += "gtk+-native libglade-native"
+
+ENABLE_BINARY_LOCALE_GENERATION = "1"
+
+# The architecture to build SDK items for, by setting this you can build SDK
+# packages for architectures other than the host i.e. building i686 packages
+# on an x86_64 host.
+# Supported values are i686 and x86_64
+#SDKMACHINE ?= "i686"
+
+# Poky can try and fetch packaged-staging packages from a http, https or ftp
+# mirror. Set this variable to the root of a pstage directory on a server.
+#SSTATE_MIRRORS ?= "\
+#file://.* http://someserver.tld/share/sstate/ \n \
+#file://.* file:///some/local/dir/sstate/"
+
+# Set IMAGETEST to qemu if you want to build testcases and start
+# testing in qemu after do_rootfs.
+#IMAGETEST = "qemu"
+
+# By default test cases in sanity suite will be ran. If you want to run other
+# test suite or specific test case(e.g. bat or boot test case under sanity suite),
+# list them like following.
+#TEST_SCEN = "sanity bat sanity:boot"
+
+#Because of the QEMU booting slowness issue(see bug #646 and #618), autobuilder
+#may suffer a timeout issue when running sanity test. We introduce variable
+#TEST_SERIALIZE here to reduce the time on sanity test. It is by default set
+#to 1. Poky will start image and run cases in the same image without reboot
+#or kill. If it is set to 0, the image will be copied and tested for each
+#case, which will take much time.
+#TEST_SERIALIZE = "1"
+
+# Set GLIBC_GENERATE_LOCALES to the locales you wish to generate should you not
+# wish to perform the time-consuming step of generating all LIBC locales.
+# NOTE: If removing en_US.UTF-8 you will also need to uncomment, and set
+# appropriate values for IMAGE_LINGUAS and LIMIT_BUILT_LOCALES
+# WARNING: this may break localisation!
+#GLIBC_GENERATE_LOCALES = "en_GB.UTF-8 en_US.UTF-8"
+# See message above as to whether setting these is required
+#IMAGE_LINGUAS ?= "en-gb"
+#LIMIT_BUILT_LOCALES ?= "POSIX en_GB"
+
+# This value is currently used by PSEUDO to determine if the recipe should
+# build both the 32-bit and 64-bit wrapper libraries on a 64-bit build system.
+#
+# PSEUDO will attempt to determine if a 32-bit wrapper is necessary, but
+# it doesn't always guess properly. If you have 32-bit executables on
+# your 64-bit build system, you likely want to set this to "0",
+# otherwise you could end up with incorrect file attributes on the
+# target filesystem.
+#
+# Default to not build 32 bit libs on 64 bit systems, comment this
+# out if that is desired
+NO32LIBS = "1"
+
+# If you do not use (or have installed) gnome-terminal you will need to
+# uncomment these variables and set them to the terminal you wish to use
+# when resolving patches which cannot be applied
+# Supported shell prefixes for *_TERMCMD and *_TERMCMDRUN ARE:
+# GNOME, SCREEN, XTERM and KONSOLE
+#TERMCMD = "${KONSOLE_TERMCMD}"
+#TERMCMDRUN = "${KONSOLE_TERMCMDRUN}"
diff --git a/meta-yocto/conf/machine/atom-pc.conf b/meta-yocto/conf/machine/atom-pc.conf
new file mode 100644
index 0000000..b94deb2
--- /dev/null
+++ b/meta-yocto/conf/machine/atom-pc.conf
@@ -0,0 +1,46 @@
+#@TYPE: Machine
+#@NAME: Atom-PC
+
+#@DESCRIPTION: Machine configuration for Intel Atom based PCs. Currently supported machines are the Asus eee901, Acer Aspire One, Toshiba NB305, and Intel BlackSand development board.
+
+TARGET_ARCH = "i586"
+
+include conf/machine/include/tune-atom.inc
+
+MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 wifi \
+ acpi"
+
+KERNEL_IMAGETYPE = "bzImage"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto-stable"
+#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
+PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
+PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
+PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
+XSERVER ?= "xserver-xf86-dri-lite \
+ xf86-input-mouse \
+ xf86-input-keyboard \
+ xf86-input-evdev \
+ xf86-input-synaptics \
+ xf86-video-intel \
+ mesa-dri-driver-i915"
+
+#MACHINE_EXTRA_RDEPENDS = "rt2860"
+
+MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
+
+GUI_MACHINE_CLASS = "bigscreen"
+
+IMAGE_ROOTFS_SIZE_ext3 = "500000"
+
+IMAGE_FSTYPES ?= "ext3 cpio.gz"
+
+APPEND += "usbcore.autosuspend=1"
+
+GLIBC_ADDONS = "nptl"
+GLIBC_EXTRA_OECONF = "--with-tls"
+
+EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi"
+
+ROOTLESS_X = "1"
diff --git a/meta-yocto/conf/machine/beagleboard.conf b/meta-yocto/conf/machine/beagleboard.conf
new file mode 100644
index 0000000..b1f7350
--- /dev/null
+++ b/meta-yocto/conf/machine/beagleboard.conf
@@ -0,0 +1,37 @@
+#@TYPE: Machine
+#@NAME: Beagleboard machine
+#@DESCRIPTION: Machine configuration for the http://beagleboard.org/ board
+TARGET_ARCH = "arm"
+
+PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
+XSERVER = "xserver-kdrive-fbdev"
+
+# Only has DVI connector for external screen
+GUI_MACHINE_CLASS = "bigscreen"
+
+#Ship all kernel modules till the board support has matured enough
+MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
+
+# Allow for MMC booting (required by the NAND-less Beagleboard XM)
+EXTRA_IMAGEDEPENDS += "u-boot x-load"
+
+#include conf/machine/include/tune-arm1136jf-s.inc
+include conf/machine/include/tune-cortexa8.inc
+
+IMAGE_FSTYPES += "tar.bz2 jffs2"
+EXTRA_IMAGECMD_jffs2 = "-lnp "
+
+# Guesswork
+SERIAL_CONSOLE = "115200 ttyO2"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
+
+KERNEL_IMAGETYPE = "uImage"
+
+UBOOT_ENTRYPOINT = "0x80008000"
+UBOOT_LOADADDRESS = "0x80008000"
+
+
+# and sdio
+MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat alsa"
diff --git a/meta-yocto/conf/machine/mpc8315e-rdb.conf b/meta-yocto/conf/machine/mpc8315e-rdb.conf
new file mode 100644
index 0000000..34b75bb
--- /dev/null
+++ b/meta-yocto/conf/machine/mpc8315e-rdb.conf
@@ -0,0 +1,20 @@
+#@TYPE: Machine
+#@DESCRIPTION: Machine configuration for running
+
+TARGET_ARCH = "powerpc"
+TARGET_FPU = "spe"
+
+require conf/machine/include/tune-ppc603e.inc
+
+KERNEL_IMAGETYPE = "uImage"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
+#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
+
+UBOOT_ENTRYPOINT = "0x00000000"
+
+KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/mpc8315erdb.dts"
diff --git a/meta-yocto/conf/machine/routerstationpro.conf b/meta-yocto/conf/machine/routerstationpro.conf
new file mode 100644
index 0000000..d464842
--- /dev/null
+++ b/meta-yocto/conf/machine/routerstationpro.conf
@@ -0,0 +1,24 @@
+#@TYPE: Machine
+#@NAME: mti_malta32_be MIPS
+#@DESCRIPTION: mti_malta32_be
+
+TARGET_ARCH = "mips"
+
+require conf/machine/include/tune-mips32.inc
+
+MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 \
+ serial usbgadget"
+
+KERNEL_IMAGETYPE = "vmlinux"
+KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
+#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
+
+IMAGE_ROOTFS_SIZE_ext3 = "2000000"
+IMAGE_FSTYPES ?= "jffs2 tar.bz2"
+
diff --git a/meta-yocto/conf/site.conf.sample b/meta-yocto/conf/site.conf.sample
new file mode 100644
index 0000000..4204204
--- /dev/null
+++ b/meta-yocto/conf/site.conf.sample
@@ -0,0 +1,40 @@
+#
+# local.conf covers user settings, site.conf covers site specific information
+# such as proxy server addresses and optionally any shared download location
+#
+# SITE_CONF_VERSION is increased each time build/conf/site.conf
+# changes incompatibly
+SCONF_VERSION = "1"
+
+# Uncomment to cause CVS to use the proxy host specified
+#CVS_PROXY_HOST = "proxy.example.com"
+#CVS_PROXY_PORT = "81"
+
+# For svn, you need to create ~/.subversion/servers containing:
+#[global]
+#http-proxy-host = proxy.example.com
+#http-proxy-port = 81
+#
+
+# Uncomment to cause git to use the proxy host specificed
+# although this only works for http
+#GIT_PROXY_HOST = "proxy.example.com"
+#GIT_PROXY_PORT = "81"
+#export GIT_PROXY_COMMAND = "${POKYBASE}/scripts/poky-git-proxy-command"
+
+# GIT_PROXY_IGNORE_* lines define hosts which do not require a proxy to access
+#GIT_CORE_CONFIG = "Yes"
+#GIT_PROXY_IGNORE_1 = "host.server.com"
+#GIT_PROXY_IGNORE_2 = "another.server.com"
+
+# If SOCKS is available run the following command to comple a simple transport
+# gcc scripts/poky-git-proxy-socks.c -o poky-git-proxy-socks
+# and then share that binary somewhere in PATH, then use the following settings
+#GIT_PROXY_HOST = "proxy.example.com"
+#GIT_PROXY_PORT = "81"
+#export GIT_PROXY_COMMAND = "${POKYBASE}/scripts/poky-git-proxy-socks-command"
+
+
+# Uncomment this to use a shared download directory
+#DL_DIR = "/some/shared/download/directory/"
+
OpenPOWER on IntegriCloud