summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.3.3.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-28 02:22:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-28 09:44:13 +0100
commit1ee92bc5d5ff1d783c8073362aefd232ee7a2dbc (patch)
tree00bc59a7f9fcd4993921e59550fc03a9b2cc2280 /meta/recipes-devtools/python/python3_3.3.3.bb
parent34195e3210d5160a04032f234202dfdb18e71e78 (diff)
downloadast2050-yocto-poky-1ee92bc5d5ff1d783c8073362aefd232ee7a2dbc.zip
ast2050-yocto-poky-1ee92bc5d5ff1d783c8073362aefd232ee7a2dbc.tar.gz
python3: fix build for shared object
Fixed when build on armv7a_vfp_neon: Python-3.3.3/Modules/_struct.o: relocation R_ARM_MOVW_ABS_NC against `a local symbol' can not be used when making a shared object; recompile with -fPIC All the archs should use -fPIC when build shared object for linux. (From OE-Core rev: 60c1f76f65060cbea458b06f9719a2536f50474e) (From OE-Core rev: d9c3d3036da6f36d1f494987aa854d0c76968a27) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.3.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.3.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.3.3.bb b/meta/recipes-devtools/python/python3_3.3.3.bb
index 6147408..897aba9 100644
--- a/meta/recipes-devtools/python/python3_3.3.3.bb
+++ b/meta/recipes-devtools/python/python3_3.3.3.bb
@@ -71,6 +71,7 @@ EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}
export CROSS_COMPILE = "${TARGET_PREFIX}"
export _PYTHON_PROJECT_BASE = "${B}"
export _PYTHON_PROJECT_SRC = "${S}"
+export CCSHARED = "-fPIC"
# No ctypes option for python 3
PYTHONLSBOPTS = ""
OpenPOWER on IntegriCloud