summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pygtk_2.24.0.bb
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2014-11-05 07:57:38 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-09 10:21:24 +0000
commit77d62cca2723c85bed0a6ac936948bceb81e9f11 (patch)
tree307be522bf5eb446843d4105d4de8a24c8d51fa0 /meta/recipes-devtools/python/python-pygtk_2.24.0.bb
parentfb4d7ece3b5e67bcab133e8d6f17d2257d04049e (diff)
downloadast2050-yocto-poky-77d62cca2723c85bed0a6ac936948bceb81e9f11.zip
ast2050-yocto-poky-77d62cca2723c85bed0a6ac936948bceb81e9f11.tar.gz
python-pygtk: Clean up incorrect "fix"
This patch removes most of "dirty fix #1" which is no longer needed (no dependency on python-pygobject-dev exists). A side effect is that the pygtk code generator will also be installed. Merge 'fix-path.inc' into this recipe as it is not used by any other recipe. (From OE-Core rev: 02985d315f71126d3af789b0666dbf428f586e4b) Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pygtk_2.24.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-pygtk_2.24.0.bb27
1 files changed, 21 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python-pygtk_2.24.0.bb b/meta/recipes-devtools/python/python-pygtk_2.24.0.bb
index bd26ebb..053f37f 100644
--- a/meta/recipes-devtools/python/python-pygtk_2.24.0.bb
+++ b/meta/recipes-devtools/python/python-pygtk_2.24.0.bb
@@ -40,16 +40,31 @@ do_configure_prepend() {
sed -i 's:tests docs:tests:' ${S}/Makefile.am
}
-# dirty fix #1: remove dependency on python-pygobject-dev
+# dirty fix #2: fix build system paths leaking in
do_install_append() {
- find ${D} -name "*.la"|xargs rm -f
- rm -f ${D}/${bindir}/pygtk-codegen-2.0
+ for i in `find ${D} -name "*.py"` ; do \
+ sed -i -e s:${D}::g $i
+ done
+
+ for i in `find ${D} -name "*.la"` ; do \
+ sed -i -e s:${STAGING_LIBDIR}:${libdir}:g $i
+ done
+
+ if test -e ${D}${bindir} ; then
+ for i in ${D}${bindir}/* ; do \
+ sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i
+ done
+ fi
+
+ if test -e ${D}${sbindir} ; then
+ for i in ${D}${sbindir}/* ; do \
+ sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i
+ done
+ fi
+
sed -i -e '1s|^#!.*python|#!/usr/bin/env python|' ${D}${bindir}/pygtk-demo
}
-# dirty fix #2: fix build system paths leaking in
-require fix-path.inc
-
PACKAGES =+ "${PN}-demo"
FILES_${PN}-demo = " ${bindir}/pygtk-demo ${libdir}/pygtk "
RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang"
OpenPOWER on IntegriCloud