summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-13 14:44:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-15 21:58:25 +0000
commit7d1e1fc6b6709856c8fbcfd1b41b9e86e50b35e2 (patch)
treee221ab0d77685d6ef6570b6ab748ea27b4d72ef2 /meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb
parent7b72a848c8991fd67ccd510f68cc793f0f722453 (diff)
downloadast2050-yocto-poky-7d1e1fc6b6709856c8fbcfd1b41b9e86e50b35e2.zip
ast2050-yocto-poky-7d1e1fc6b6709856c8fbcfd1b41b9e86e50b35e2.tar.gz
python-pycurl: 7.19.5 -> 7.19.5.1
(From OE-Core rev: a95c7fe895583fc145300d739d0bcac30626c588) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb b/meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb
new file mode 100644
index 0000000..0d0effe
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Python bindings for libcurl"
+HOMEPAGE = "http://pycurl.sourceforge.net/"
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1+ | MIT"
+LIC_FILES_CHKSUM = "file://README.rst;beginline=166;endline=181;md5=57e5ab0c0f964533fc59d93dec5695bb \
+ file://COPYING-LGPL;md5=3579a9fd0221d49a237aaa33492f988c \
+ file://COPYING-MIT;md5=e8200955c773b2a0fd6cea36ea5e87be"
+
+DEPENDS = "curl python"
+RDEPENDS_${PN} = "python-core curl"
+SRCNAME = "pycurl"
+
+SRC_URI = "\
+ http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
+ file://no-static-link.patch \
+"
+
+SRC_URI[archive.md5sum] = "f44cd54256d7a643ab7b16e3f409b26b"
+SRC_URI[archive.sha256sum] = "6e9770f80459757f73bd71af82fbb29cd398b38388cdf1beab31ea91a331bc6c"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+# need to export these variables for python-config to work
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+BBCLASSEXTEND = "native"
+
+# Ensure the docstrings are generated as make clean will remove them
+do_compile_prepend() {
+ ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py docstrings
+}
+
+do_install_append() {
+ rm -rf ${D}${datadir}/share
+}
OpenPOWER on IntegriCloud