summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.9.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-02-20 15:40:47 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-23 17:35:29 +0000
commit360dbb52530e7bd5b7ae942b7d2732e2f845a64c (patch)
tree2d85c4fb123de2b6caa23bdf7ef5d3bb2a5c354f /meta/recipes-devtools/python/python-native_2.7.9.bb
parentcb02ecb507ddad3cb17c78020b42c004aa2903ae (diff)
downloadast2050-yocto-poky-360dbb52530e7bd5b7ae942b7d2732e2f845a64c.zip
ast2050-yocto-poky-360dbb52530e7bd5b7ae942b7d2732e2f845a64c.tar.gz
python-native: Reverts usage of distutils.sysconfig On older versions of Python, sysconfig read the Makefile and Python.h, generated at build time now it uses _sysconfigdata which contains information about the HOST, erroneous in our case, this causes an error when bulding something using distutils since it obtains compiler information and such.
Also fixes configuration of _ctypes/libffi (From OE-Core rev: 3c76d5ef1f4d5270c94661d9fde7e31391b5cc2d) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.9.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.9.bb25
1 files changed, 13 insertions, 12 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.9.bb b/meta/recipes-devtools/python/python-native_2.7.9.bb
index dfde361..54be2ea 100644
--- a/meta/recipes-devtools/python/python-native_2.7.9.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.9.bb
@@ -5,17 +5,18 @@ DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native s
PR = "${INC_PR}.1"
SRC_URI += "\
- file://05-enable-ctypes-cross-build.patch \
- file://10-distutils-fix-swig-parameter.patch \
- file://11-distutils-never-modify-shebang-line.patch \
- file://12-distutils-prefix-is-inside-staging-area.patch \
- file://debug.patch \
- file://unixccompiler.patch \
- file://nohostlibs.patch \
- file://multilib.patch \
- file://add-md5module-support.patch \
- file://builddir.patch \
- file://parallel-makeinst-create-bindir.patch \
+ file://05-enable-ctypes-cross-build.patch \
+ file://10-distutils-fix-swig-parameter.patch \
+ file://11-distutils-never-modify-shebang-line.patch \
+ file://12-distutils-prefix-is-inside-staging-area.patch \
+ file://debug.patch \
+ file://unixccompiler.patch \
+ file://nohostlibs.patch \
+ file://multilib.patch \
+ file://add-md5module-support.patch \
+ file://builddir.patch \
+ file://parallel-makeinst-create-bindir.patch \
+ file://revert_use_of_sysconfigdata.patch \
"
S = "${WORKDIR}/Python-${PV}"
@@ -36,7 +37,7 @@ EXTRA_OEMAKE = '\
'
do_configure_prepend() {
- autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
+ autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
}
do_install() {
OpenPOWER on IntegriCloud