summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-imaging_1.1.7.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-03-15 13:17:58 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-16 10:57:09 +0000
commitbe0f9dd483af2a2f55b2ae8ef9ca172e7c90819c (patch)
treeace680fa870f648d397575f48e693e3530ccc6ce /meta/recipes-devtools/python/python-imaging_1.1.7.bb
parent24d15606096b79bdf9961f99b6857ae138fa3da1 (diff)
downloadast2050-yocto-poky-be0f9dd483af2a2f55b2ae8ef9ca172e7c90819c.zip
ast2050-yocto-poky-be0f9dd483af2a2f55b2ae8ef9ca172e7c90819c.tar.gz
python-imaging: bring in fixes from meta-oe
This makes the following changes: * Replace the /usr/local/bin/python path in all scripts * Move RDEPENDS_${PN} to the end (but use += or we lose the python-core depencency). * Use PR = "r3" instead of "ml2". (Even without increasing the numeric part it is recognised as greater alphabetically.) * Bring in meta-oe version of the path patch which avoids the following warning: WARNING: python-imaging: The compile log indicates that host include and/or library paths were used. (From OE-Core rev: 9950163c91412eb58c3475354cc7f87a7be33c2b) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-imaging_1.1.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-imaging_1.1.7.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python-imaging_1.1.7.bb b/meta/recipes-devtools/python/python-imaging_1.1.7.bb
index fc568b5..6d9743e 100644
--- a/meta/recipes-devtools/python/python-imaging_1.1.7.bb
+++ b/meta/recipes-devtools/python/python-imaging_1.1.7.bb
@@ -3,12 +3,11 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://README;beginline=92;endline=120;md5=c4371af4579f1e489cf881c1443dd4ec"
DEPENDS = "freetype jpeg tiff"
-RDEPENDS_${PN} = "python-lang python-stringold"
SRCNAME = "Imaging"
-PR = "ml2"
+PR = "r3"
SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
- file://path.patch"
+ file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch"
SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e"
SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211"
@@ -30,4 +29,8 @@ do_install() {
install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
+ # get rid of #!/usr/local/bin/python
+ sed -i -e 's:/usr/local/bin/:${bindir}/env :g' ${D}${bindir}/*
}
+
+RDEPENDS_${PN} += "python-lang python-stringold"
OpenPOWER on IntegriCloud