summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-native_2.4.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-08 11:10:56 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:25 -0800
commit563953df47785bf57969d86b9b5f8494e585a28c (patch)
tree4b9d4cdb858f08894503dcd5233e6bcf5ed7ab6e /meta/recipes-devtools/libtool/libtool-native_2.4.bb
parentaa5befab23679e07441805e18d9b6f3f271b5ed5 (diff)
downloadast2050-yocto-poky-563953df47785bf57969d86b9b5f8494e585a28c.zip
ast2050-yocto-poky-563953df47785bf57969d86b9b5f8494e585a28c.tar.gz
libtool upgrade from 2.2.10 to 2.4
Taking out of this code from patch as the newer upstream code has fix, and this patch is not needed. cross-compile.patch: -Index: libtool-2.2.10/libltdl/config/ltmain.m4sh +Index: libtool-2.4/libltdl/config/ltmain.m4sh =================================================================== ---- libtool-2.2.10.orig/libltdl/config/ltmain.m4sh -+++ libtool-2.2.10/libltdl/config/ltmain.m4sh -@@ -5147,8 +5147,14 @@ func_mode_link () - absdir="$abs_ladir" - libdir="$abs_ladir" - else -- dir="$libdir" -- absdir="$libdir" -+ # Adding 'libdir' from the .la file to our library search paths -+ # breaks crosscompilation horribly. We cheat here and don't add -+ # it, instead adding the path where we found the .la. -CL -+ dir="$abs_ladir" -+ absdir="$abs_ladir" -+ libdir="$abs_ladir" -+ #dir="$libdir" -+ #absdir="$libdir" - fi - test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes - else Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-native_2.4.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.bb
new file mode 100644
index 0000000..f10ea88
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.bb
@@ -0,0 +1,22 @@
+require libtool_${PV}.bb
+
+DEPENDS = ""
+
+PR = "r0"
+SRC_URI_append = " file://cross_compile.patch \
+ file://prefix.patch "
+
+inherit native
+
+do_configure_prepend () {
+ # Remove any existing libtool m4 since old stale versions would break
+ # any upgrade
+ rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
+ rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
+}
OpenPOWER on IntegriCloud