summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.148.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-05-23 18:53:59 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-25 15:50:56 +0100
commita49cc20ad2e28cdd974f79da3463597dd31ab647 (patch)
treee1f5eb44172d3ef7ba683c6b8594abede8ca9d00 /meta/recipes-devtools/elfutils/elfutils_0.148.bb
parentc792ca026a92682cb7aff44fbfb66ba80568c037 (diff)
downloadast2050-yocto-poky-a49cc20ad2e28cdd974f79da3463597dd31ab647.zip
ast2050-yocto-poky-a49cc20ad2e28cdd974f79da3463597dd31ab647.tar.gz
elfutils_0.148.bb: Fix compilation on uclibc
Currently all components of elfutils dont compile with uclibc but elfutils is one part which is needed by other recipes e.g. gcc 4.5 to compile. we make adjustments so that when compiling for uclibc targets it _only_ builds and packages libelf use --enable-uclibc only when building for uclibc targets The supporting patch is also needed for compiling with uclibc to specify -lintl and -luargp on linker commandline Add missing inherit on gettext (From OE-Core rev: e21267f1837b25fec4443dbf4367e501639541bd) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.148.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.148.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.148.bb b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
index df933f6..115ff9b 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.148.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
@@ -30,6 +30,9 @@ SRC_URI += "\
file://remove-unused.patch \
file://mempcpy.patch \
"
+# Only apply when building uclibc based target recipe
+SRC_URI_append_libc-uclibc = " ${@['', 'file://uclibc-support.patch']['${PN}' == '${BPN}']}"
+
# The buildsystem wants to generate 2 .h files from source using a binary it just built,
# which can not pass the cross compiling, so let's work around it by adding 2 .h files
# along with the do_configure_prepend()
@@ -38,9 +41,10 @@ SRC_URI += "\
file://i386_dis.h \
file://x86_64_dis.h \
"
-inherit autotools
+inherit autotools gettext
EXTRA_OECONF = "--program-prefix=eu-"
+EXTRA_OECONF_append_libc-uclibc = " ${@['', '--enable-uclibc']['${PN}' == '${BPN}']}"
do_configure_prepend() {
sed -i 's:./i386_gendis:echo\ \#:g' ${S}/libcpu/Makefile.am
@@ -48,8 +52,13 @@ do_configure_prepend() {
cp ${WORKDIR}/*dis.h ${S}/libcpu
}
-# Only append ldflags for target recipe
-TARGET_LDFLAGS_libc-uclibc += "${@['', '-lintl -luargp']['${PN}' == '${BPN}']}"
+# we can not build complete elfutils when using uclibc
+# but some recipes e.g. gcc 4.5 depends on libelf so we
+# build only libelf for uclibc case
+
+EXTRA_OEMAKE_libc-uclibc = "-C libelf"
+EXTRA_OEMAKE_virtclass-native = ""
+EXTRA_OEMAKE_virtclass-nativesdk = ""
BBCLASSEXTEND = "native nativesdk"
OpenPOWER on IntegriCloud