summaryrefslogtreecommitdiffstats
path: root/meta-yocto/recipes-core
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-04-20 11:45:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-05 16:09:17 +0100
commite72210c791fa2565b7922bdc6542fc064203930b (patch)
tree6c6b66f86b53fa0be66ee0348d769aedbf37f2fd /meta-yocto/recipes-core
parent001a555c2f755d4f8a69b113656d9307ca7ee597 (diff)
downloadast2050-yocto-poky-e72210c791fa2565b7922bdc6542fc064203930b.zip
ast2050-yocto-poky-e72210c791fa2565b7922bdc6542fc064203930b.tar.gz
netbase: automatically bring up usb0 on BeagleBoard xM
Avoids manual configuration of the BeagleBoard xM's ethernet port (which shows up as usb0). Fixes [YOCTO #930] Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-yocto/recipes-core')
-rw-r--r--meta-yocto/recipes-core/netbase/netbase-4.45/beagleboard/interfaces27
-rw-r--r--meta-yocto/recipes-core/netbase/netbase_4.45.bbappend3
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-yocto/recipes-core/netbase/netbase-4.45/beagleboard/interfaces b/meta-yocto/recipes-core/netbase/netbase-4.45/beagleboard/interfaces
new file mode 100644
index 0000000..b6935c1
--- /dev/null
+++ b/meta-yocto/recipes-core/netbase/netbase-4.45/beagleboard/interfaces
@@ -0,0 +1,27 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+# Wireless interfaces
+iface wlan0 inet dhcp
+ wireless_mode managed
+ wireless_essid any
+ wpa-driver wext
+ wpa-conf /etc/wpa_supplicant.conf
+
+iface atml0 inet dhcp
+
+# Wired or wireless interfaces
+auto eth0
+iface eth0 inet dhcp
+iface eth1 inet dhcp
+
+# Ethernet/RNDIS gadget (g_ether) or LAN9514 on BeagleBoard xM
+auto usb0
+iface usb0 inet dhcp
+
+# Bluetooth networking
+iface bnep0 inet dhcp
+
diff --git a/meta-yocto/recipes-core/netbase/netbase_4.45.bbappend b/meta-yocto/recipes-core/netbase/netbase_4.45.bbappend
new file mode 100644
index 0000000..4b8d0e6
--- /dev/null
+++ b/meta-yocto/recipes-core/netbase/netbase_4.45.bbappend
@@ -0,0 +1,3 @@
+THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
+FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
+
OpenPOWER on IntegriCloud