summaryrefslogtreecommitdiffstats
path: root/meta-rt
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2010-12-28 09:23:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:36:58 +0000
commit238c13f10603e3566cbdd79ecc4c358aa9ab9fcc (patch)
tree68d1b76e2a818c80eefc3c5383e9b304efcc6416 /meta-rt
parent8734754b3ebd815de1eb5d7c648f528d0ca75a4b (diff)
downloadast2050-yocto-poky-238c13f10603e3566cbdd79ecc4c358aa9ab9fcc.zip
ast2050-yocto-poky-238c13f10603e3566cbdd79ecc4c358aa9ab9fcc.tar.gz
meta-rt: atom-pc support
Add support for the atom-pc machine to the meta-rt layer. This has been boot tested on the Intel n450 development board (Black Sand). Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Tom Zanussi <tom.zanussi@intel.com> CC: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-rt')
-rw-r--r--meta-rt/conf/layer.conf3
-rw-r--r--meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb3
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-rt/conf/layer.conf b/meta-rt/conf/layer.conf
index dbf4a32..94ebc02 100644
--- a/meta-rt/conf/layer.conf
+++ b/meta-rt/conf/layer.conf
@@ -17,6 +17,7 @@ BBFILE_PRIORITY_rt = "8"
PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt"
# preempt_rt SRCREVs, one for meta, one per machine
-SRCREV_meta_pn-linux-yocto-rt ?= "50ccd2b3213b6a1bacb3f898c035119802dac420"
+SRCREV_meta_pn-linux-yocto-rt ?= "b0615811ce38836d1ade230e3bdb1efaaa68471f"
SRCREV_machine_pn-linux-yocto-rt_qemux86-64 ?= "f49444f06875894389e640bcda6c3f6ceb1f0c3e"
+SRCREV_machine_pn-linux-yocto-rt_atom-pc ?= "78dacaf8222c9492ba17f652989ef3466423bdc2"
diff --git a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb b/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
index 361b680..547f8fe 100644
--- a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
+++ b/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
@@ -2,6 +2,7 @@ inherit kernel
require recipes-kernel/linux/linux-yocto.inc
KMACHINE_qemux86-64 = "common_pc_64"
+KMACHINE_atom-pc = "atom-pc"
LINUX_VERSION ?= "2.6.34"
LINUX_KERNEL_TYPE = "preempt_rt"
@@ -11,7 +12,7 @@ PR = "r0"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRCREV_FORMAT = "meta_machine"
-COMPATIBLE_MACHINE = "(qemux86-64)"
+COMPATIBLE_MACHINE = "(qemux86-64|atom-pc)"
# this performs a fixup on the SRCREV for new/undefined BSPs
python __anonymous () {
OpenPOWER on IntegriCloud