summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-support
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-support
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadast2050-yocto-poky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.zip
ast2050-yocto-poky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-support')
-rw-r--r--meta-demoapps/recipes-support/iso-codes/iso-codes_3.3.bb14
-rw-r--r--meta-demoapps/recipes-support/libfribidi/files/libtool-update.patch11
-rw-r--r--meta-demoapps/recipes-support/libfribidi/libfribidi_0.10.4.bb24
-rw-r--r--meta-demoapps/recipes-support/openobex/files/disable-cable-test.patch16
-rw-r--r--meta-demoapps/recipes-support/openobex/files/libusb_crosscompile_check.patch13
-rw-r--r--meta-demoapps/recipes-support/openobex/openobex_1.5.bb23
-rw-r--r--meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb16
-rw-r--r--meta-demoapps/recipes-support/poppler/poppler-fpu.inc6
-rw-r--r--meta-demoapps/recipes-support/poppler/poppler.inc18
-rw-r--r--meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb2
10 files changed, 143 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-support/iso-codes/iso-codes_3.3.bb b/meta-demoapps/recipes-support/iso-codes/iso-codes_3.3.bb
new file mode 100644
index 0000000..23d025f
--- /dev/null
+++ b/meta-demoapps/recipes-support/iso-codes/iso-codes_3.3.bb
@@ -0,0 +1,14 @@
+SECTION = "libs"
+DESCRIPTION = "ISO language, territory, currency, script codes and their translations"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+SECTION = "libs"
+PACKAGE_ARCH = "all"
+
+SRC_URI = "ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/iso-codes-${PV}.tar.gz"
+
+inherit autotools
+
+FILES_${PN}-dev="${datadir}/pkgconfig/iso-codes.pc"
+FILES_${PN}="${datadir}/xml/iso-codes/ \
+ ${datadir}/iso-codes/"
diff --git a/meta-demoapps/recipes-support/libfribidi/files/libtool-update.patch b/meta-demoapps/recipes-support/libfribidi/files/libtool-update.patch
new file mode 100644
index 0000000..c703100
--- /dev/null
+++ b/meta-demoapps/recipes-support/libfribidi/files/libtool-update.patch
@@ -0,0 +1,11 @@
+--- fribidi-0.10.4/configure.in~ 2002-05-19 11:06:48.000000000 +0100
++++ fribidi-0.10.4/configure.in 2004-08-03 17:42:28.000000000 +0100
+@@ -50,7 +50,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+-AC_PROG_RANLIB
++#AC_PROG_RANLIB
+ AC_PATH_PROG(SED, sed, $PATH)
+
+
diff --git a/meta-demoapps/recipes-support/libfribidi/libfribidi_0.10.4.bb b/meta-demoapps/recipes-support/libfribidi/libfribidi_0.10.4.bb
new file mode 100644
index 0000000..d60a190
--- /dev/null
+++ b/meta-demoapps/recipes-support/libfribidi/libfribidi_0.10.4.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Fribidi library for bidirectional text"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+inherit autotools pkgconfig
+
+PR = "r0"
+
+S = "${WORKDIR}/fribidi-${PV}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/fribidi/fribidi-${PV}.tar.bz2 \
+ file://libtool-update.patch;patch=1"
+
+#PACKAGES += " ${PN}-bin"
+FILES_${PN} = "${libdir}/lib*.so.*"
+#FILES_${PN}-bin = "${libdir}/uu*"
+
+do_configure_prepend () {
+# this version of libtool is old - we have to nobble this file to get it to litoolize
+ rm ltconfig
+ rm aclocal.m4
+ rm acinclude.m4
+}
diff --git a/meta-demoapps/recipes-support/openobex/files/disable-cable-test.patch b/meta-demoapps/recipes-support/openobex/files/disable-cable-test.patch
new file mode 100644
index 0000000..95b636d
--- /dev/null
+++ b/meta-demoapps/recipes-support/openobex/files/disable-cable-test.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- openobex-1.2/apps/Makefile.am~disable-cable-test
++++ openobex-1.2/apps/Makefile.am
+@@ -6,7 +6,7 @@
+ obex_io.c obex_io.h \
+ obex_put_common.c obex_put_common.h
+
+-bin_PROGRAMS = irxfer obex_tcp irobex_palm3 obex_test
++bin_PROGRAMS = irxfer obex_tcp irobex_palm3
+
+ obex_test_SOURCES = \
+ obex_test.c obex_test.h \
diff --git a/meta-demoapps/recipes-support/openobex/files/libusb_crosscompile_check.patch b/meta-demoapps/recipes-support/openobex/files/libusb_crosscompile_check.patch
new file mode 100644
index 0000000..20ac70b
--- /dev/null
+++ b/meta-demoapps/recipes-support/openobex/files/libusb_crosscompile_check.patch
@@ -0,0 +1,13 @@
+Index: openobex-1.5/acinclude.m4
+===================================================================
+--- openobex-1.5.orig/acinclude.m4 2009-02-08 18:30:22.000000000 +0000
++++ openobex-1.5/acinclude.m4 2009-07-31 09:55:46.000000000 +0100
+@@ -158,7 +158,7 @@
+ ;;
+ *)
+ PKG_CHECK_MODULES(USB, libusb, usb_lib_found=yes, AC_MSG_RESULT(no))
+- AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="libusb")
++ REQUIRES="libusb"
+ ;;
+ esac
+ AC_SUBST(USB_CFLAGS)
diff --git a/meta-demoapps/recipes-support/openobex/openobex_1.5.bb b/meta-demoapps/recipes-support/openobex/openobex_1.5.bb
new file mode 100644
index 0000000..dc07ae1
--- /dev/null
+++ b/meta-demoapps/recipes-support/openobex/openobex_1.5.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+PROVIDES = "openobex-apps"
+DEPENDS = "libusb bluez4"
+LICENSE = "GPL"
+PR = "r4"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/bluetooth/openobex-${PV}.tar.gz \
+ file://disable-cable-test.patch;patch=1 \
+ file://libusb_crosscompile_check.patch;patch=1"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+ --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+# how to stop shlibrename from renaming -apps?
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"
diff --git a/meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb b/meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb
new file mode 100644
index 0000000..ca22e4d
--- /dev/null
+++ b/meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base."
+LICENSE = "Adobe"
+PR = "r0"
+
+SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz"
+
+do_compile() {
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} += "${datadir}"
+PACKAGE_ARCH = "all"
+
diff --git a/meta-demoapps/recipes-support/poppler/poppler-fpu.inc b/meta-demoapps/recipes-support/poppler/poppler-fpu.inc
new file mode 100644
index 0000000..a262730
--- /dev/null
+++ b/meta-demoapps/recipes-support/poppler/poppler-fpu.inc
@@ -0,0 +1,6 @@
+
+def get_poppler_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--enable-fixedpoint"
+ return ""
+
diff --git a/meta-demoapps/recipes-support/poppler/poppler.inc b/meta-demoapps/recipes-support/poppler/poppler.inc
new file mode 100644
index 0000000..645e734
--- /dev/null
+++ b/meta-demoapps/recipes-support/poppler/poppler.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base."
+DEPENDS = "fontconfig jpeg zlib gtk+ cairo"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --enable-xpdf-headers \
+ --disable-gtk-test \
+ --disable-poppler-qt --disable-poppler-qt4 \
+ --enable-zlib \
+ "
+
+#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require poppler-fpu.inc
+EXTRA_OECONF += "${@get_poppler_fpu_setting(bb, d)}"
diff --git a/meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb b/meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb
new file mode 100644
index 0000000..92c25bc
--- /dev/null
+++ b/meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb
@@ -0,0 +1,2 @@
+require poppler.inc
+PR = "r2"
OpenPOWER on IntegriCloud