summaryrefslogtreecommitdiffstats
path: root/meta-raptor/meta-asus/recipes-kernel/com-e-mod/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raptor/meta-asus/recipes-kernel/com-e-mod/files/Makefile')
-rw-r--r--meta-raptor/meta-asus/recipes-kernel/com-e-mod/files/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-raptor/meta-asus/recipes-kernel/com-e-mod/files/Makefile b/meta-raptor/meta-asus/recipes-kernel/com-e-mod/files/Makefile
new file mode 100644
index 0000000..d3b524e
--- /dev/null
+++ b/meta-raptor/meta-asus/recipes-kernel/com-e-mod/files/Makefile
@@ -0,0 +1,31 @@
+# Copyright 2015-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+
+obj-m := com_e_driver.o
+
+SRC := $(shell pwd)
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
+ rm -f Module.markers Module.symvers modules.order
+ rm -rf .tmp_versions Modules.symvers
OpenPOWER on IntegriCloud