summaryrefslogtreecommitdiffstats
path: root/meta-facebook/meta-wedge/recipes-wedge/ipmid/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook/meta-wedge/recipes-wedge/ipmid/files/Makefile')
-rw-r--r--meta-facebook/meta-wedge/recipes-wedge/ipmid/files/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-facebook/meta-wedge/recipes-wedge/ipmid/files/Makefile b/meta-facebook/meta-wedge/recipes-wedge/ipmid/files/Makefile
new file mode 100644
index 0000000..8282964
--- /dev/null
+++ b/meta-facebook/meta-wedge/recipes-wedge/ipmid/files/Makefile
@@ -0,0 +1,13 @@
+# Copyright 2014-present Facebook. All Rights Reserved.
+all: ipmid
+
+ipmid: ipmid.c \
+ platform/timestamp.c platform/sel.c platform/sdr.c \
+ platform/wedge/sensor.c \
+ platform/wedge/fruid.c
+ $(CC) -pthread -lwedge_eeprom -std=c99 -o $@ $^ $(LDFLAGS)
+
+.PHONY: clean
+
+clean:
+ rm -rf *.o platform/*.o platform/wedge/*.o ipmid
OpenPOWER on IntegriCloud